summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2020-05-09 14:37:19 -0700
committerDonald Webster2020-05-09 14:37:19 -0700
commit4cdc8e1b43465219455361a5adde7889b3093cd9 (patch)
tree41c5f7857c8352f18ae3d002ae1439a322fea6e2
downloadaur-4cdc8e1b43465219455361a5adde7889b3093cd9.tar.gz
Initial version of readarr-nightly package w/ v0.1.0.66.
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD62
-rw-r--r--package_info3
-rw-r--r--readarr.service17
-rw-r--r--readarr.sysusers1
-rw-r--r--readarr.tmpfiles4
7 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cbbd6d74c6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = readarr-nightly
+ pkgdesc = Audio and eBook download automation for usenet and torrents.
+ pkgver = 0.1.0.66
+ pkgrel = 1
+ url = https://github.com/Readarr/Readarr
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = GPL3
+ depends = sqlite
+ optdepends = calibre: calibre-server as root folder
+ optdepends = sabnzbd: usenet downloader
+ optdepends = nzbget: usenet downloader
+ optdepends = transmission-cli: torrent downloader (CLI and daemon)
+ optdepends = transmission-gtk: torrent downloader (GTK+)
+ optdepends = transmission-qt: torrent downloader (Qt)
+ optdepends = deluge: torrent downloader
+ optdepends = rtorrent: torrent downloader
+ optdepends = qbittorrent: torrent downloader
+ optdepends = qbittorrent-nox: torrent downloader (no X)
+ optdepends = jackett: torrent indexer proxy
+ provides = readarr
+ conflicts = readarr
+ options = !strip
+ options = staticlibs
+ source = readarr.service
+ source = readarr.tmpfiles
+ source = readarr.sysusers
+ source = package_info
+ sha512sums = ffcc3297f44f31daf21c79febcd6730a79ffd1e46cdb256f9b23a85ede4d026a6d6272aae23d1d055b3295b848be1385ce6d4c7b93b910b15be1e05f2aa04c27
+ sha512sums = b34389cf2966a7a1a1fe6708303641e144191a95001c5ca6e570e9d50ba334fcbc1603852c3c2bfe008d97aaf54207690c689f00dd63378157af33ceebbbb089
+ sha512sums = 99f8210754ea5ec742ba6b0b9f05c8312237cb0225bc0d28a2a8ee8362b464da0880499b64ea58c84b64c0eb727748c3c15630cedb8785d7d94d856c76cf17eb
+ sha512sums = f762a01de8c4448a64da61fc6804587b2679d3c2b874c42cd920d7af0a380ed4c93ff8e89aac72a1cdca90c98596d97f593c98f6528326e4dacfc3f09ab536a5
+ source_x86_64 = readarr.0.1.0.66.linux-core-x64.tar.gz::https://readarr.servarr.com/v1/update/nightly/updatefile?version=0.1.0.66&os=linux&runtime=netcore&arch=x64
+ sha512sums_x86_64 = 31475aa9fd7977e6d0a16a3dc3f4337aecc2f17541c94f0f256c43abd89249982230d879db4c85b4e0e40796a401b2dc0919b841176e910f19b91d0d2543855e
+ source_aarch64 = readarr.0.1.0.66.linux-core-arm64.tar.gz::https://readarr.servarr.com/v1/update/nightly/updatefile?version=0.1.0.66&os=linux&runtime=netcore&arch=arm64
+ sha512sums_aarch64 = 31475aa9fd7977e6d0a16a3dc3f4337aecc2f17541c94f0f256c43abd89249982230d879db4c85b4e0e40796a401b2dc0919b841176e910f19b91d0d2543855e
+ source_armv7h = readarr.0.1.0.66.linux-core-arm.tar.gz::https://readarr.servarr.com/v1/update/nightly/updatefile?version=0.1.0.66&os=linux&runtime=netcore&arch=arm
+ sha512sums_armv7h = 31475aa9fd7977e6d0a16a3dc3f4337aecc2f17541c94f0f256c43abd89249982230d879db4c85b4e0e40796a401b2dc0919b841176e910f19b91d0d2543855e
+
+pkgname = readarr-nightly
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..126ef55ce320
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+*.gz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4db62c835a79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Donald Webster <fryfrog@gmail.com>
+# Helpful url: https://readarr.servarr.com/v1/update/readarr/updatefile?os=linux&runtime=netcore&arch=x64
+
+pkgname="readarr-nightly"
+pkgver=0.1.0.66
+pkgrel=1
+pkgdesc="Audio and eBook download automation for usenet and torrents."
+arch=('x86_64' 'aarch64' 'armv7h')
+url="https://github.com/Readarr/Readarr"
+license=("GPL3")
+depends=('sqlite')
+options=('!strip' 'staticlibs')
+provides=('readarr')
+conflicts=('readarr')
+optdepends=('calibre: calibre-server as root folder'
+ 'sabnzbd: usenet downloader'
+ 'nzbget: usenet downloader'
+ 'transmission-cli: torrent downloader (CLI and daemon)'
+ 'transmission-gtk: torrent downloader (GTK+)'
+ 'transmission-qt: torrent downloader (Qt)'
+ 'deluge: torrent downloader'
+ 'rtorrent: torrent downloader'
+ 'qbittorrent: torrent downloader'
+ 'qbittorrent-nox: torrent downloader (no X)'
+ 'jackett: torrent indexer proxy')
+
+source_x86_64=("readarr.${pkgver}.linux-core-x64.tar.gz::https://readarr.servarr.com/v1/update/nightly/updatefile?version=${pkgver}&os=linux&runtime=netcore&arch=x64")
+source_aarch64=("readarr.${pkgver}.linux-core-arm64.tar.gz::https://readarr.servarr.com/v1/update/nightly/updatefile?version=${pkgver}&os=linux&runtime=netcore&arch=arm64")
+source_armv7h=("readarr.${pkgver}.linux-core-arm.tar.gz::https://readarr.servarr.com/v1/update/nightly/updatefile?version=${pkgver}&os=linux&runtime=netcore&arch=arm")
+
+source=('readarr.service'
+ 'readarr.tmpfiles'
+ 'readarr.sysusers'
+ 'package_info')
+
+sha512sums=('ffcc3297f44f31daf21c79febcd6730a79ffd1e46cdb256f9b23a85ede4d026a6d6272aae23d1d055b3295b848be1385ce6d4c7b93b910b15be1e05f2aa04c27'
+ 'b34389cf2966a7a1a1fe6708303641e144191a95001c5ca6e570e9d50ba334fcbc1603852c3c2bfe008d97aaf54207690c689f00dd63378157af33ceebbbb089'
+ '99f8210754ea5ec742ba6b0b9f05c8312237cb0225bc0d28a2a8ee8362b464da0880499b64ea58c84b64c0eb727748c3c15630cedb8785d7d94d856c76cf17eb'
+ 'f762a01de8c4448a64da61fc6804587b2679d3c2b874c42cd920d7af0a380ed4c93ff8e89aac72a1cdca90c98596d97f593c98f6528326e4dacfc3f09ab536a5')
+sha512sums_x86_64=('31475aa9fd7977e6d0a16a3dc3f4337aecc2f17541c94f0f256c43abd89249982230d879db4c85b4e0e40796a401b2dc0919b841176e910f19b91d0d2543855e')
+sha512sums_aarch64=('31475aa9fd7977e6d0a16a3dc3f4337aecc2f17541c94f0f256c43abd89249982230d879db4c85b4e0e40796a401b2dc0919b841176e910f19b91d0d2543855e')
+sha512sums_armv7h=('31475aa9fd7977e6d0a16a3dc3f4337aecc2f17541c94f0f256c43abd89249982230d879db4c85b4e0e40796a401b2dc0919b841176e910f19b91d0d2543855e')
+
+
+
+package() {
+ # Update environment isn't needed.
+ rm -rf "${srcdir}/Readarr/Readarr.Update"
+
+ install -d -m 755 "${pkgdir}/usr/lib/readarr/bin"
+ cp -dpr --no-preserve=ownership "${srcdir}/Readarr/"* "${pkgdir}/usr/lib/readarr/bin"
+ chmod -R a=,a+rX,u+w "${pkgdir}/usr/lib/readarr/bin"
+ chmod +x "${pkgdir}/usr/lib/readarr/bin/Readarr"
+
+ # Disable built in updater.
+ install -D -m 644 "${srcdir}/package_info" "${pkgdir}/usr/lib/readarr"
+ echo "PackageVersion=${pkgver}-${pkgrel}" >> "${pkgdir}/usr/lib/readarr/package_info"
+
+ install -D -m 644 "${srcdir}/readarr.service" "${pkgdir}/usr/lib/systemd/system/readarr.service"
+ install -D -m 644 "${srcdir}/readarr.sysusers" "${pkgdir}/usr/lib/sysusers.d/readarr.conf"
+ install -D -m 644 "${srcdir}/readarr.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/readarr.conf"
+}
diff --git a/package_info b/package_info
new file mode 100644
index 000000000000..2294849db24c
--- /dev/null
+++ b/package_info
@@ -0,0 +1,3 @@
+PackageAuthor=fryfrog
+UpdateMethod=External
+Branch=nightly
diff --git a/readarr.service b/readarr.service
new file mode 100644
index 000000000000..dc2a99688c20
--- /dev/null
+++ b/readarr.service
@@ -0,0 +1,17 @@
+[Unit]
+Description=Readarr Service
+After=syslog.target network.target
+
+[Service]
+User=readarr
+Group=readarr
+ExecStart=/usr/lib/readarr/bin/Readarr -nobrowser -data=/var/lib/readarr
+Type=simple
+TimeoutStopSec=20
+
+# Lets built in updater work well.
+Restart=on-failure
+KillMode=process
+
+[Install]
+WantedBy=multi-user.target
diff --git a/readarr.sysusers b/readarr.sysusers
new file mode 100644
index 000000000000..52c0c5e6e7cb
--- /dev/null
+++ b/readarr.sysusers
@@ -0,0 +1 @@
+u readarr - "Readarr daemon" /var/lib/readarr
diff --git a/readarr.tmpfiles b/readarr.tmpfiles
new file mode 100644
index 000000000000..bbd2d565aeb0
--- /dev/null
+++ b/readarr.tmpfiles
@@ -0,0 +1,4 @@
+# Override this file with a modified version in /etc/tmpfiles.d/
+d /var/lib/readarr 0755 readarr readarr
+Z /var/lib/readarr - readarr readarr
+L /var/log/readarr - - - - /var/lib/readarr/logs