summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonny Lorenz2015-09-19 10:36:50 +0200
committerRonny Lorenz2015-09-19 10:36:50 +0200
commit6ef00254c1d3131535cee7d1a8dac316d49d1329 (patch)
treed46a10c6de226a8eea346212544c76cfb5aeaf0c
downloadaur-6ef00254c1d3131535cee7d1a8dac316d49d1329.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
-rw-r--r--arch-readseq.readme12
-rw-r--r--license6
-rw-r--r--readseq.sh13
5 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ebdd3f84795
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = readseq
+ pkgdesc = A biosequence data format conversion tool
+ pkgver = 2.1.30
+ pkgrel = 2
+ url = http://iubio.bio.indiana.edu/soft/molbio/readseq/java/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-runtime
+ depends = bash
+ source = http://iubio.bio.indiana.edu/soft/molbio/readseq/java/readseq.jar
+ source = http://iubio.bio.indiana.edu/soft/molbio/readseq/java/readseq-help.html
+ source = http://iubio.bio.indiana.edu/soft/molbio/readseq/java/Readseq2-help.html
+ source = readseq.sh
+ source = license
+ source = arch-readseq.readme
+ md5sums = 0b40df0f7e1283e03c09bfcf70cb381c
+ md5sums = d1a73902a66a6b210e751be9d0e8e6c6
+ md5sums = 389be807c8037976b6ae06a9ebe178aa
+ md5sums = 177bad15a8f79db2678850ac3718973f
+ md5sums = 51fb18f9b72171d0943807fce97d3cab
+ md5sums = 72f9ff0c2e17eab8883c09ec98bf0e91
+
+pkgname = readseq
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55167d158cc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Mick Elliot <micke at sfu dot ca>
+# Contributor: Ronny Lorenz < ronny at tbi.univie.ac.at >
+# Contributor: Mick Elliot <micke at sfu dot ca>
+
+pkgname=readseq
+pkgver=2.1.30
+origver=2.1.27
+pkgrel=2
+pkgdesc="A biosequence data format conversion tool"
+arch=('i686' 'x86_64')
+url="http://iubio.bio.indiana.edu/soft/molbio/${pkgname}/java/"
+license=('custom')
+depends=('java-runtime' 'bash')
+source=( "${url}${pkgname}.jar"
+ "${url}${pkgname}-help.html"
+ "${url}Readseq2-help.html"
+ "readseq.sh"
+ "license"
+ "arch-readseq.readme")
+
+md5sums=('0b40df0f7e1283e03c09bfcf70cb381c'
+ 'd1a73902a66a6b210e751be9d0e8e6c6'
+ '389be807c8037976b6ae06a9ebe178aa'
+ '177bad15a8f79db2678850ac3718973f'
+ '51fb18f9b72171d0943807fce97d3cab'
+ '72f9ff0c2e17eab8883c09ec98bf0e91')
+
+package() {
+ # cd $startdir/src/
+ install -D -m755 readseq.sh "${pkgdir}/usr/bin/${pkgname}"
+ chmod +x "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 license "${pkgdir}/usr/share/licenses/${pkgname}/license"
+ install -D -m644 ${pkgname}.jar "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar"
+ install -D -m644 ${pkgname}-help.html "${pkgdir}/usr/share/doc/${pkgname}/${pkgname}-help.html"
+ install -D -m644 Readseq2-help.html "${pkgdir}/usr/share/doc/${pkgname}/${pkgname}2-help.html"
+ install -D -m644 arch-readseq.readme "${pkgdir}/usr/share/doc/${pkgname}/arch-readseq.readme"
+ echo "***************************************************************************"
+ echo "Documentation and arch-specific instructions are in /usr/share/doc/readseq/"
+ echo "***************************************************************************"
+}
+
diff --git a/arch-readseq.readme b/arch-readseq.readme
new file mode 100644
index 000000000000..fab5d553eb4e
--- /dev/null
+++ b/arch-readseq.readme
@@ -0,0 +1,12 @@
+The readseq jar file is located at /usr/share/java/readseq/readseq.jar
+
+Normally readseq is used by typing a command such as:
+java -cp /usr/share/java/readseq/readseq.jar run myfile -f 12 -o outfile
+
+For the arch installation, a script has been placed at /usr/bin/readseq that passes command line args to the readseq jar file.
+So, to run the java command given above, you just need to type:
+readseq run myfile -f 12 -o outfile
+
+If you run /usr/bin/readseq without command line arguments, readseq will open as a gui application.
+
+
diff --git a/license b/license
new file mode 100644
index 000000000000..894ec9ef08fd
--- /dev/null
+++ b/license
@@ -0,0 +1,6 @@
+Anyone can use Readseq. There are no copyright restrictions, it is in the PUBLIC DOMAIN.
+
+-- Don Gilbert
+software@bio.indiana.edu, May 2001
+Bioinformatics group, Biology Department & Cntr. Genomics & Bioinformatics,
+Indiana University, Bloomington, Indiana
diff --git a/readseq.sh b/readseq.sh
new file mode 100644
index 000000000000..c3f30e95e616
--- /dev/null
+++ b/readseq.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+for arg
+do
+ cmd="$cmd $arg"
+done
+
+if [ ${#cmd} -eq 0 ]; then
+ java -cp /usr/share/java/readseq/readseq.jar app
+ else
+ java -cp /usr/share/java/readseq/readseq.jar $cmd
+fi
+