summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCrocoDuck2016-03-10 21:04:49 +0000
committerCrocoDuck2016-03-10 21:04:49 +0000
commit063b97d1b8f168817ae0c3b4b21385414464cef7 (patch)
treea032fc8803e20e4cad055c50ea4a77379eeb3f2e
parent5d69635a31cda2dfe6959472385913638b6ed965 (diff)
downloadaur-063b97d1b8f168817ae0c3b4b21385414464cef7.tar.gz
Added pkgver() function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30cfe30f659c..73219e0399df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = realtimeconfigquickscan-git
pkgdesc = Linux configuration checker for systems to be used for real-time audio
pkgver = r16.c362fbb
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/raboof/realtimeconfigquickscan
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index b4d0cded0e18..70ec6dd14a3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=realtimeconfigquickscan-git
pkgver=r16.c362fbb
-pkgrel=2
+pkgrel=3
pkgdesc="Linux configuration checker for systems to be used for real-time audio"
arch=('any')
url="https://github.com/raboof/realtimeconfigquickscan"
@@ -17,6 +17,11 @@ source=("${pkgname%-*}"::"git://github.com/raboof/realtimeconfigquickscan"
'QuickScan')
md5sums=('SKIP' '45847f5cbc4880b6e724fa4fafbdc3c7' '8e3ff9238a56c66fb2f50f4f36259a95')
+pkgver() {
+ cd "${pkgname%-*}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
package() {
cd ${pkgname%-*}
# Install Script Files: