summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAliaksandr Stelmachonak a.k.a. ava1ar2017-09-10 23:16:38 -0400
committerAliaksandr Stelmachonak a.k.a. ava1ar2017-09-10 23:16:38 -0400
commit4ee9f8fc39a56de7a11dbe16cc4b502fea3ca46d (patch)
tree58e2c8abe786aedf7a0690735ee98dea4da88736
downloadaur-4ee9f8fc39a56de7a11dbe16cc4b502fea3ca46d.tar.gz
Initial commit after RealVNC split of server and client
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD25
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8f2666a3c02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Mon Sep 11 03:16:25 UTC 2017
+pkgbase = realvnc-vnc-viewer
+ pkgdesc = VNC remote desktop client software by RealVNC
+ pkgver = 6.17.731
+ pkgrel = 1
+ url = https://www.realvnc.com/
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ license = custom
+ depends = glibc
+ depends = gcc-libs
+ depends = libice
+ depends = libsm
+ depends = libx11
+ depends = libxext
+ conflicts = tightvnc
+ conflicts = tigervnc
+ conflicts = turbovnc
+ options = !strip
+ source_x86_64 = https://www.realvnc.com/download/file/viewer.files/VNC-Viewer-6.17.731-Linux-x64.deb
+ sha1sums_x86_64 = 7c313833e701f1358e325cc43a8aaef9da04be3f
+ source_i686 = https://www.realvnc.com/download/file/viewer.files/VNC-Viewer-6.17.731-Linux-x86.deb
+ sha1sums_i686 = 9c328727776fe6abf33a9270b5af3a17364a8686
+ source_armv7h = https://www.realvnc.com/download/file/viewer.files/VNC-Viewer-6.17.731-Linux-ARM.deb
+ sha1sums_armv7h = a2c8b6169a2d843dc4076135c699868c63760d83
+
+pkgname = realvnc-vnc-viewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85ae6f3415ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Star Brilliant <echo bTEzMjUzQGhvdG1haWwuY29tCg== | base64 -d>
+# Maintainer: ava1ar <mail(at)ava1ar(dot)me>
+
+pkgname=realvnc-vnc-viewer
+pkgver=6.17.731
+pkgrel=1
+pkgdesc='VNC remote desktop client software by RealVNC'
+arch=('x86_64' 'i686' 'armv7h')
+url='https://www.realvnc.com/'
+license=('custom')
+depends=('glibc' 'gcc-libs' 'libice' 'libsm' 'libx11' 'libxext')
+conflicts=('tightvnc' 'tigervnc' 'turbovnc')
+source_x86_64=("https://www.realvnc.com/download/file/viewer.files/VNC-Viewer-${pkgver}-Linux-x64.deb")
+source_i686=("https://www.realvnc.com/download/file/viewer.files/VNC-Viewer-${pkgver}-Linux-x86.deb")
+source_armv7h=("https://www.realvnc.com/download/file/viewer.files/VNC-Viewer-${pkgver}-Linux-ARM.deb")
+sha1sums_x86_64=('7c313833e701f1358e325cc43a8aaef9da04be3f')
+sha1sums_i686=('9c328727776fe6abf33a9270b5af3a17364a8686')
+sha1sums_armv7h=('a2c8b6169a2d843dc4076135c699868c63760d83')
+options=(!strip)
+
+package() {
+ bsdtar -xv -C "${pkgdir}" -f "${srcdir}/data.tar.gz"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s /usr/share/doc/${pkgname}/copyright "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}