summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjandob2016-02-21 19:21:20 +0100
committerjandob2016-02-21 19:24:46 +0100
commitfe2e2a0b37d3a85b0686a3937d64cf793e4eb935 (patch)
treee6b8105f04c23deb39b1582a3cda45b1fd4a14d1
downloadaur-fe2e2a0b37d3a85b0686a3937d64cf793e4eb935.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
-rwxr-xr-xsetup_git_hooks11
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c5c77d2e037
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Feb 21 18:24:46 UTC 2016
+pkgbase = rebash
+ pkgdesc = bash/shell library/framework
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/jandob/rebash
+ arch = x86_64
+ license = WTFPL
+ makedepends = git
+ depends = bash sed grep
+ source = git+https://github.com/jandob/rebash.git
+ md5sums = SKIP
+
+pkgname = rebash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d77f7fae08f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Janosch Dobler <janosch.dobler@gmx.de>
+pkgname=rebash
+pkgver=0.1
+pkgrel=1
+pkgdesc="bash/shell library/framework"
+arch=('x86_64')
+url="https://github.com/jandob/rebash"
+license=('WTFPL')
+depends=('bash sed grep')
+makedepends=('git')
+source=('git+https://github.com/jandob/rebash.git')
+md5sums=('SKIP')
+
+package() {
+ mkdir -p "${pkgdir}/usr/lib/rebash"
+ install -Dm755 "${srcdir}"/rebash/* "${pkgdir}/usr/lib/rebash/"
+}
diff --git a/setup_git_hooks b/setup_git_hooks
new file mode 100755
index 000000000000..b45f29d98180
--- /dev/null
+++ b/setup_git_hooks
@@ -0,0 +1,11 @@
+#!/usr/bin/env bash
+echo '#!/bin/sh
+branch=$(git rev-parse --symbolic --abbrev-ref HEAD)
+if [ "master" == "$branch" ]; then
+ echo running pre-commit hook for aur
+ echo generating .SRCINFO
+ mksrcinfo
+ git add .SRCINFO
+fi
+' > .git/hooks/pre-commit
+chmod +x .git/hooks/pre-commit