summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-27 18:14:28 +0800
committerzxp198210052023-10-27 18:14:28 +0800
commitd555597306ec76efc3720ee400f37f5c6071759d (patch)
tree52da506cb54e2bb81e17ceef803080ff7bd17c1e
downloadaur-d555597306ec76efc3720ee400f37f5c6071759d.tar.gz
update to 3.7.3
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--rebaslight.sh10
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e94df480b4d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = rebaslight-bin
+ pkgdesc = An easy to use special effects editor
+ pkgver = 3.7.3
+ pkgrel = 1
+ url = http://www.rebaslight.com/
+ arch = x86_64
+ license = AGPL3
+ makedepends = gendesk
+ depends = bash
+ depends = electron25
+ provides = rebaslight=3.7.3
+ conflicts = rebaslight
+ source = rebaslight-3.7.3.tar.bz2::https://github.com/rebaslight/rebaslight/releases/download/v3.7.3/rebaslight-3.7.3.tar.bz2
+ source = rebaslight.png::https://raw.githubusercontent.com/rebaslight/rebaslight/v3.7.3/src/img/logo-transparent-100.png
+ source = rebaslight.sh
+ sha256sums = d322a41100fcacb12658d3cef76ec21070081445d4f8868befa8c8edf267abd0
+ sha256sums = 62c76391a01e5d25c078cd65b2b0c78f39c756d041fef426043abfee38f0697c
+ sha256sums = 7045452f79743a68d66c11d065db619a627e9569250e5b742db3ab48abd412cb
+
+pkgname = rebaslight-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4988959cbd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=rebaslight-bin
+_pkgname="Rebaslight"
+pkgver=3.7.3
+pkgrel=1
+pkgdesc="An easy to use special effects editor"
+arch=("x86_64")
+url="http://www.rebaslight.com/"
+_ghurl="https://github.com/rebaslight/rebaslight"
+license=('AGPL3')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'bash'
+ 'electron25'
+)
+makedepends=(
+ 'gendesk'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.tar.bz2::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}.tar.bz2"
+ "${pkgname%-bin}.png::https://raw.githubusercontent.com/rebaslight/rebaslight/v${pkgver}/src/img/logo-transparent-100.png"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('d322a41100fcacb12658d3cef76ec21070081445d4f8868befa8c8edf267abd0'
+ '62c76391a01e5d25c078cd65b2b0c78f39c756d041fef426043abfee38f0697c'
+ '7045452f79743a68d66c11d065db619a627e9569250e5b742db3ab48abd412cb')
+build() {
+ gendesk -f -n -q --categories "AudioVideo" --name "${_pkgname}" --exec "${pkgname}"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}-${pkgver}/resources/ffmpeg" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file
diff --git a/rebaslight.sh b/rebaslight.sh
new file mode 100644
index 000000000000..0242c778706e
--- /dev/null
+++ b/rebaslight.sh
@@ -0,0 +1,10 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron25
+APPDIR="/usr/lib/rebaslight"
+export PATH="${APPDIR}:${PATH}"
+_ASAR="${APPDIR}/app.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file