summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-27 13:04:18 +0800
committerzxp198210052024-02-27 13:04:18 +0800
commited7265c0fe722800579ac1e02ace7837cb612a29 (patch)
treedbefb36c5f153f3de29aa2b38819eedb74cfe6c4
parent5c5d9601639d75452e1135c23db5e08a038b5dd4 (diff)
downloadaur-ed7265c0fe722800579ac1e02ace7837cb612a29.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--rebaslight.sh9
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a65f954f8e77..69a53ffd2872 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = rebaslight-bin
pkgdesc = An easy to use special effects editor
pkgver = 3.7.3
- pkgrel = 3
+ pkgrel = 4
url = http://www.rebaslight.com/
arch = x86_64
- license = AGPL3
+ license = AGPL-3.0-only
makedepends = gendesk
depends = electron25
provides = rebaslight=3.7.3
@@ -14,6 +14,6 @@ pkgbase = rebaslight-bin
source = rebaslight.sh
sha256sums = d322a41100fcacb12658d3cef76ec21070081445d4f8868befa8c8edf267abd0
sha256sums = 62c76391a01e5d25c078cd65b2b0c78f39c756d041fef426043abfee38f0697c
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = rebaslight-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0690f0c1e8b6..78444aa1c83a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@ pkgname=rebaslight-bin
_pkgname="Rebaslight"
pkgver=3.7.3
_electronversion=25
-pkgrel=3
+pkgrel=4
pkgdesc="An easy to use special effects editor"
arch=("x86_64")
url="http://www.rebaslight.com/"
_ghurl="https://github.com/rebaslight/rebaslight"
-license=('AGPL3')
+license=('AGPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -24,13 +24,13 @@ source=(
)
sha256sums=('d322a41100fcacb12658d3cef76ec21070081445d4f8868befa8c8edf267abd0'
'62c76391a01e5d25c078cd65b2b0c78f39c756d041fef426043abfee38f0697c'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -f -n -q --categories "AudioVideo" --name "${_pkgname}" --exec "${pkgname} %U"
+ gendesk -f -n -q --categories="AudioVideo" --name="${_pkgname}" --exec="${pkgname} %U"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/rebaslight.sh b/rebaslight.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/rebaslight.sh
+++ b/rebaslight.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file