summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2021-03-06 13:51:39 +1000
committerMark Blakeney2021-03-06 13:51:39 +1000
commitf4fea3fed54c998cc2f603c0d671b4f3620ceee2 (patch)
tree2be7c761de7fa98413eccd1f802432bf47bd0800
downloadaur-f4fea3fed54c998cc2f603c0d671b4f3620ceee2.tar.gz
Initial version 1.2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e23b2d7a27ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rebind-devices
+ pkgdesc = Linux service to automatically reset devices when resuming from sleep
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/bulletmark/rebind-devices
+ arch = any
+ license = GPL3
+ depends = python>=3.6
+ backup = etc/rebind-devices.conf
+ source = rebind-devices-1.2.tar.gz::https://github.com/bulletmark/rebind-devices/archive/1.2.tar.gz
+ md5sums = 2d35bf8853fe3a0818e19dd75e19000d
+
+pkgname = rebind-devices
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6dd39bbd03b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar
+*.[gx]z
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dbbc10295f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: mark.blakeney at bullet-systems dot net
+pkgname=rebind-devices
+pkgver=1.2
+pkgrel=1
+pkgdesc="Linux service to automatically reset devices when resuming from sleep"
+url="https://github.com/bulletmark/$pkgname"
+license=("GPL3")
+arch=("any")
+depends=("python>=3.6")
+backup=("etc/$pkgname.conf")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+md5sums=('2d35bf8853fe3a0818e19dd75e19000d')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: