summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Nestler2019-11-19 22:56:51 +0100
committerRaphael Nestler2019-11-19 22:56:51 +0100
commita1e2b594050888dbe11fd223aa1ebc2727a982c8 (patch)
tree168703c00b7d9ce7ac70f94ee7a40063e9ca2379
downloadaur-a1e2b594050888dbe11fd223aa1ebc2727a982c8.tar.gz
Initial version with 0.1.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcfcefe78760
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = reboot-arch-btw
+ pkgdesc = Check if you need to reboot due to an updated kernel
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/rnestler/reboot-arch-btw
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = cargo
+ depends = dbus
+ replaces = kernel-updated
+ source = https://github.com/rnestler/reboot-arch-btw/archive/v0.1.2.tar.gz
+ sha256sums = 64ba53fab74bfbf9befc4ea38fb96f065bef150487c9d158b6a21a6c57d7d9cd
+
+pkgname = reboot-arch-btw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e232c863a17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: rnestler
+
+pkgname=reboot-arch-btw
+pkgver=0.1.2
+pkgrel=1
+pkgdesc='Check if you need to reboot due to an updated kernel'
+arch=('i686' 'x86_64')
+url="https://github.com/rnestler/reboot-arch-btw"
+license=('GPL3')
+makedepends=('rust' 'cargo')
+depends=('dbus')
+replaces=('kernel-updated')
+source=("https://github.com/rnestler/reboot-arch-btw/archive/v${pkgver}.tar.gz")
+sha256sums=('64ba53fab74bfbf9befc4ea38fb96f065bef150487c9d158b6a21a6c57d7d9cd')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "${pkgdir}/usr/bin"
+ cp -p target/release/${pkgname} "${pkgdir}/usr/bin"
+}