summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-12-24 10:02:12 -0700
committeryochananmarqos2019-12-24 10:02:12 -0700
commit62c919e2954a087e9c577ad082f785e24e3afc27 (patch)
tree17ffee242343f541a7e606efe010880c5d89a61f
downloadaur-62c919e2954a087e9c577ad082f785e24e3afc27.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b9396a7a68b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rebound
+ pkgdesc = Command-line tool that instantly fetches Stack Overflow results when an exception is thrown
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/shobrook/rebound
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-requests
+ depends = python-urwid
+ source = rebound-2.0.0.tar.gz::https://github.com/shobrook/rebound/archive/v2.0.0.tar.gz
+ sha256sums = 8d5cd356c17416dcdb90b34c09e793cb24550fbf00ac32a8ff85d58a312173f6
+
+pkgname = rebound
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f13d598431b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=rebound
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Command-line tool that instantly fetches Stack Overflow results when an exception is thrown"
+arch=('any')
+url="https://github.com/shobrook/rebound"
+license=('MIT')
+depends=('python-beautifulsoup4' 'python-requests' 'python-urwid')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('8d5cd356c17416dcdb90b34c09e793cb24550fbf00ac32a8ff85d58a312173f6')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ pytest
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}