summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-02-28 10:32:08 -0700
committerMark Wagie2021-02-28 10:32:08 -0700
commitf8e6de0c09a05f94ba7b2ff188a46c42c6db0814 (patch)
treebcbb8ad28f16739ed3e34451a53dc5b97a0c453e
parent494894a2bf0ca72000f01601433d071d4dad6894 (diff)
downloadaur-f8e6de0c09a05f94ba7b2ff188a46c42c6db0814.tar.gz
2.1.0
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD32
3 files changed, 30 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b9396a7a68b..a588339099fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = rebound
pkgdesc = Command-line tool that instantly fetches Stack Overflow results when an exception is thrown
- pkgver = 2.0.0
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/shobrook/rebound
arch = any
license = MIT
- checkdepends = python-pytest
makedepends = python-setuptools
depends = python-beautifulsoup4
depends = python-requests
depends = python-urwid
- source = rebound-2.0.0.tar.gz::https://github.com/shobrook/rebound/archive/v2.0.0.tar.gz
- sha256sums = 8d5cd356c17416dcdb90b34c09e793cb24550fbf00ac32a8ff85d58a312173f6
+ source = https://pypi.org/packages/source/r/rebound-cli/rebound-cli-2.1.0.tar.gz
+ sha256sums = 19e2065a140a64abb53d8553b6faa15db89a851e9909225786cb6997e56c03c7
pkgname = rebound
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 6ebd5f688719..a1aafc261fcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=rebound
-#_name="$pkgname-cli"
-pkgver=2.0.0
+_name="$pkgname-cli"
+pkgver=2.1.0
pkgrel=1
pkgdesc="Command-line tool that instantly fetches Stack Overflow results when an exception is thrown"
arch=('any')
@@ -9,22 +9,30 @@ url="https://github.com/shobrook/rebound"
license=('MIT')
depends=('python-beautifulsoup4' 'python-requests' 'python-urwid')
makedepends=('python-setuptools')
-checkdepends=('python-pytest')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-#source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('8d5cd356c17416dcdb90b34c09e793cb24550fbf00ac32a8ff85d58a312173f6')
+#checkdepends=('python-pytest')
+#source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('19e2065a140a64abb53d8553b6faa15db89a851e9909225786cb6997e56c03c7')
+
+prepare() {
+ cd "$_name-$pkgver"
+
+ # Correct version
+ sed -i "s/V1.1.9a1/V$pkgver/g" "$pkgname/$pkgname.py"
+}
build() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
python setup.py build
}
-check() {
- cd "$pkgname-$pkgver"
- pytest
-}
+#check() {
+# cd "$_name-$pkgver"
+# pytest
+#}
package() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
+ export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}