summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn FrostFox2020-06-11 00:27:53 +0300
committerJohn FrostFox2020-06-11 00:27:53 +0300
commit4d19912a4fba95070696d49d58938b4b78b6a6e6 (patch)
tree8c844980ffa408e73164a3a4999ac4a3f2bf3ef8
parent9bc2cc657c246ea22e7e027262d1471e80d3ea5e (diff)
downloadaur-4d19912a4fba95070696d49d58938b4b78b6a6e6.tar.gz
added optdepends for MP4 rec
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84352d14e787..aabb6e0bf8ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,6 +18,8 @@ pkgbase = recapp-git
depends = python-pydbus
depends = slop
depends = python-pulse-control
+ optdepends = gst-plugins-bad: for MP4 recording
+ optdepends = gst-plugins-ugly: for MP4 recording
source = recapp-git::git+https://github.com/amikha1lov/RecApp.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 462530528919..c675f2900e97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,29 +7,30 @@ arch=('any')
url="https://github.com/amikha1lov/RecApp"
license=('GPL3')
depends=('gst-plugins-base' 'gst-plugins-good' 'hicolor-icon-theme' 'python-pydbus' 'slop' 'python-pulse-control')
-# optdepends=('gst-plugins-ugly')
+optdepends=('gst-plugins-bad: for MP4 recording'
+ 'gst-plugins-ugly: for MP4 recording')
makedepends=('meson' 'ninja' 'git' 'intltool' 'appstream-glib' 'desktop-file-utils' 'python')
source=(${pkgname}::'git+'${url}'.git')
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g;s/rc.\.//'
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g;s/rc.\.//'
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}"
arch-meson --buildtype=plain build
ninja -C build
}
check() {
- cd "${srcdir}/${pkgname}"
- arch-meson check
+ cd "${srcdir}/${pkgname}"
+ arch-meson check
}
package() {
- cd "${srcdir}/${pkgname}"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ cd "${srcdir}/${pkgname}"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
DESTDIR="$pkgdir" ninja -C build install
} \ No newline at end of file