summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn FrostFox2020-05-16 19:48:50 +0300
committerJohn FrostFox2020-05-16 19:48:50 +0300
commit59e3e63fb4aeabd157b9970203b28595f94629d6 (patch)
tree82e5e9a4a78ef4eefffa9aa60bf0124b04a7cc1b
downloadaur-59e3e63fb4aeabd157b9970203b28595f94629d6.tar.gz
Initial commit to AUR
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD35
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c307156702c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = recapp-git
+ pkgdesc = Simple screen recorder for Linux written in GTK, using only GStreamer.
+ pkgver = 1.0.2.r0.g0c911ee
+ pkgrel = 1
+ url = https://github.com/amikha1lov/RecApp
+ arch = any
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ makedepends = git
+ makedepends = intltool
+ makedepends = appstream-glib
+ makedepends = desktop-file-utils
+ makedepends = python
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = hicolor-icon-theme
+ depends = python-pydbus
+ depends = slop
+ depends = python-pulse-control
+ source = recapp-git-1.0.2.r0.g0c911ee::git+https://github.com/amikha1lov/RecApp.git
+ md5sums = SKIP
+
+pkgname = recapp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38e8c9498206
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: John FrostFox <john.frostfox at gmail dot com>
+pkgname=recapp-git
+pkgver=1.0.2.r0.g0c911ee
+pkgrel=1
+pkgdesc="Simple screen recorder for Linux written in GTK, using only GStreamer."
+arch=('any')
+url="https://github.com/amikha1lov/RecApp"
+license=('GPL3')
+depends=('gst-plugins-base' 'gst-plugins-good' 'hicolor-icon-theme' 'python-pydbus' 'slop' 'python-pulse-control')
+# optdepends=('gst-plugins-ugly')
+makedepends=('meson' 'ninja' 'git' 'intltool' 'appstream-glib' 'desktop-file-utils' 'python')
+source=(${pkgname}-${pkgver}::'git+'${url}'.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g;s/rc.\.//'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ arch-meson --buildtype=plain build
+ ninja -C build
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ arch-meson check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ DESTDIR="$pkgdir" ninja -C build install
+} \ No newline at end of file