summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGhostNaN2020-10-05 13:12:29 -0400
committerGhostNaN2020-10-05 13:12:29 -0400
commit25579be693165bcc7a25866d7c8bdc8d31f095b4 (patch)
treef0fef5d4854e1676dbeeb94bbf0087b48f095a7f
parent8293f09aa3515cc47aa8bfae5b4a15df866d4625 (diff)
downloadaur-25579be693165bcc7a25866d7c8bdc8d31f095b4.tar.gz
Update and Dep change
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a56d54373feb..62f16d28b230 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = recidia-audio-visualizer
pkgdesc = A highly customizable real time audio visualizer
- pkgver = 0.1
+ pkgver = 0.1.1
pkgrel = 1
url = https://github.com/GhostNaN/recidia-audio-visualizer
arch = i686
arch = x86_64
license = GPL3
- makedepends = git
makedepends = meson
makedepends = ninja
depends = gsl
depends = fftw
depends = ncurses
depends = libconfig
- depends = portaudio
- optdepends = pulseaudio
- source = recidia-audio-visualizer-0.1.tar.gz::https://github.com/GhostNaN/recidia-audio-visualizer/archive/0.1.tar.gz
- sha256sums = f1a6f8e2a2d56e9f57bb26e08987b50900664e5f0a221733416635359e51fae5
+ optdepends = pulseaudio: Audio data collection - PICK ONE/BOTH
+ optdepends = portaudio: Audio data collection (Input Only) - PICK ONE/BOTH
+ source = recidia-audio-visualizer-0.1.1.tar.gz::https://github.com/GhostNaN/recidia-audio-visualizer/archive/0.1.1.tar.gz
+ sha256sums = edb796a51a3ba7080e2e455cd571fa4d7ac6e32316d980bb6ee688c5e1b3ec6e
pkgname = recidia-audio-visualizer
diff --git a/PKGBUILD b/PKGBUILD
index 4a0aaf9d19aa..b7e59e110537 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: GhostNaN <GhostNaN@protonmail.com>
_gitname=recidia-audio-visualizer
pkgname="$_gitname"
-pkgver=0.1
+pkgver=0.1.1
pkgrel=1
pkgdesc="A highly customizable real time audio visualizer"
arch=('i686' 'x86_64')
url="https://github.com/GhostNaN/$_gitname"
license=('GPL3')
-depends=('gsl' 'fftw' 'ncurses' 'libconfig' 'portaudio')
-makedepends=('git' 'meson' 'ninja')
-optdepends=('pulseaudio')
+depends=('gsl' 'fftw' 'ncurses' 'libconfig')
+makedepends=('meson' 'ninja')
+optdepends=('pulseaudio: Audio data collection - PICK ONE/BOTH'
+ 'portaudio: Audio data collection (Input Only) - PICK ONE/BOTH')
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/GhostNaN/$_gitname/archive/$pkgver.tar.gz)
-sha256sums=('f1a6f8e2a2d56e9f57bb26e08987b50900664e5f0a221733416635359e51fae5')
+sha256sums=('edb796a51a3ba7080e2e455cd571fa4d7ac6e32316d980bb6ee688c5e1b3ec6e')
build() {
cd $pkgname-$pkgver
@@ -26,6 +27,4 @@ package() {
install -D settings.cfg $pkgdir/etc/recidia/
DESTDIR="$pkgdir" ninja -C build install
-
-
}