summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGhostNaN2020-10-02 23:37:04 -0400
committerGhostNaN2020-10-02 23:37:04 -0400
commit55582b360ce5f01d2ccb19e938a2d11bbdee1466 (patch)
treee70c3888e6857079a61f0439ee27a88b3b0a14d0
downloadaur-55582b360ce5f01d2ccb19e938a2d11bbdee1466.tar.gz
Create PKGBUILD
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1d14fc18420
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = recidia-audio-visualizer
+ pkgdesc = A highly customizable real time audio visualizer
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/GhostNaN/recidia-audio-visualizer
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = pkgconf
+ depends = gsl
+ depends = fftw
+ depends = ncurses
+ depends = libconfig
+ depends = portaudio
+ optdepends = pulseaudio
+ source = recidia-audio-visualizer-0.1.tar.gz::https://github.com/GhostNaN/recidia-audio-visualizer/archive/0.1.tar.gz
+ sha256sums = afdbd0f069e857b62bbb30ca3ba34ee95a7b8334c02711a4c82829bf206dfd0d
+
+pkgname = recidia-audio-visualizer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ba605f4d410
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: GhostNaN <GhostNaN@protonmail.com>
+_gitname=recidia-audio-visualizer
+pkgname="$_gitname"
+pkgver=0.1
+pkgrel=1
+pkgdesc="A highly customizable real time audio visualizer"
+arch=('i686' 'x86_64')
+url="https://github.com/GhostNaN/$_gitname"
+license=('GPL3')
+depends=('gsl' 'fftw' 'ncurses' 'libconfig' 'portaudio')
+makedepends=('git' 'meson' 'ninja' 'pkgconf')
+optdepends=('pulseaudio')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/GhostNaN/$_gitname/archive/$pkgver.tar.gz)
+sha256sums=('afdbd0f069e857b62bbb30ca3ba34ee95a7b8334c02711a4c82829bf206dfd0d')
+
+build() {
+ cd $pkgname-$pkgver
+ meson build --prefix=/usr
+ ninja -C build
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ mkdir -p $pkgdir/etc/recidia/
+ install -D settings.cfg $pkgdir/etc/recidia/
+
+ DESTDIR="$pkgdir" ninja -C build install
+
+
+}