summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiels Abspoel2015-06-08 21:52:41 +0200
committerNiels Abspoel2015-06-08 21:52:41 +0200
commit481e9d1511411643b75eddb8bf3bb0dcedf31349 (patch)
tree08bfffbee6036df470270907e5255f3073dbeeea
downloadaur-481e9d1511411643b75eddb8bf3bb0dcedf31349.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
-rw-r--r--reclass-config.yml1
4 files changed, 80 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..97a657055fc8
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = reclass
+ pkgdesc = hierarchical inventory backend for configuration management systems (salt, ansible, puppet)
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = http://reclass.pantsfullofunix.net/
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ depends = python2
+ provides = reclass
+ conflicts = reclass-git
+ backup = etc/reclass/reclass-config.yml
+ source = http://debian.c3sl.ufpr.br/debian/pool/main/r/reclass/reclass_1.4.1.orig.tar.gz
+ source = reclass-config.yml
+ md5sums = bb8d46cd739ca76befb12ebc70e79b14
+ md5sums = ad011bd9cf89152b9eaaeebc0862732f
+
+pkgname = reclass
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5b9de8a249b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = reclass
+ pkgdesc = hierarchical inventory backend for configuration management systems (salt, ansible, puppet)
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = http://reclass.pantsfullofunix.net/
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ depends = python2
+ provides = reclass
+ conflicts = reclass-git
+ backup = etc/reclass/reclass-config.yml
+ source = http://debian.c3sl.ufpr.br/debian/pool/main/r/reclass/reclass_1.4.1.orig.tar.gz
+ source = reclass-config.yml
+ source = .AURINFO
+ md5sums = bb8d46cd739ca76befb12ebc70e79b14
+ md5sums = ad011bd9cf89152b9eaaeebc0862732f
+ md5sums = SKIP
+
+pkgname = reclass
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95cc6f6d12fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Niels Abspoel <aboe76@gmail.com>
+pkgname=reclass
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="hierarchical inventory backend for configuration management systems (salt, ansible, puppet)"
+arch=('i686' 'x86_64')
+url="http://reclass.pantsfullofunix.net/"
+license=("PerlArtistic")
+depends=('python2')
+backup=('etc/reclass/reclass-config.yml')
+makedepends=()
+optdepends=()
+options=()
+conflicts=('reclass-git')
+provides=('reclass')
+source=("http://debian.c3sl.ufpr.br/debian/pool/main/r/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz" 'reclass-config.yml' '.AURINFO')
+md5sums=('bb8d46cd739ca76befb12ebc70e79b14' 'ad011bd9cf89152b9eaaeebc0862732f' 'SKIP')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ #create default dir
+ mkdir -p $pkgdir/etc/reclass/nodes
+ mkdir -p $pkgdir/etc/reclass/classes
+ install -Dm644 ${srcdir}/reclass-config.yml ${pkgdir}/etc/reclass/reclass-config.yml
+
+ #examples are usefull
+ mkdir -p $pkgdir/usr/share/doc/${pkgname}/examples
+ for i in ${srcdir}/${pkgname}-${pkgver}/examples/*; do
+ cp -R $i ${pkgdir}/usr/share/doc/${pkgname}/examples/"$(basename $i)"
+ chown -R root:root ${pkgdir}/usr/share/doc/${pkgname}/examples/"$(basename $i)"
+ done
+}
diff --git a/reclass-config.yml b/reclass-config.yml
new file mode 100644
index 000000000000..aabe8085c0f6
--- /dev/null
+++ b/reclass-config.yml
@@ -0,0 +1 @@
+inventory_base_uri: /etc/reclass