summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmily Maré (emileet)2020-06-01 16:52:55 +1000
committerEmily Maré (emileet)2020-06-01 16:52:55 +1000
commit4d0624822e45a570e13fc62cab9fbc080675e5c6 (patch)
tree982bd35fbf4296af45a3bb01e230c3fb5db6c420
parent033b2e4a7ff9c755757e07f8b1b79ea93721db93 (diff)
downloadaur-4d0624822e45a570e13fc62cab9fbc080675e5c6.tar.gz
fix scrollbar crash (should upstream this)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--linux-get-scroll-info.patch21
3 files changed, 29 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee347c887b1b..222555fd65c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = reclass.net-git
pkgdesc = A reverse-engineering tool for dissecting data structures in memory
pkgver = 1.2.r140.g534b684
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ReClassNET/ReClass.NET
arch = x86_64
license = MIT
@@ -12,9 +12,11 @@ pkgbase = reclass.net-git
source = git+https://github.com/ReClassNET/ReClass.NET.git
source = linux-native-plugin-path.patch
source = linux-windows-sections.patch
+ source = linux-get-scroll-info.patch
sha256sums = SKIP
sha256sums = 78d3136c874a2c43042cf4685aa8520a25145c09e7118d3c1724df5a10caf613
sha256sums = 66d87fec0d6f330ba518cd7d97abaeeb6fb2c2f3232fb7229d13264a54aeaa15
+ sha256sums = 894f4caf2a440d193e3c411142d92e956df6db8362709c178a88e791e6399192
pkgname = reclass.net-git
diff --git a/PKGBUILD b/PKGBUILD
index a8c311ad068b..1670f6def00b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=reclass.net-git
_pkgname=ReClass.NET
pkgver=1.2.r140.g534b684
-pkgrel=1
+pkgrel=2
pkgdesc="A reverse-engineering tool for dissecting data structures in memory"
arch=('x86_64')
license=('MIT')
@@ -13,10 +13,12 @@ depends=('mono')
makedepends=('git' 'mono-msbuild')
source=("git+https://github.com/ReClassNET/ReClass.NET.git"
"linux-native-plugin-path.patch"
- "linux-windows-sections.patch")
+ "linux-windows-sections.patch"
+ "linux-get-scroll-info.patch")
sha256sums=('SKIP'
'78d3136c874a2c43042cf4685aa8520a25145c09e7118d3c1724df5a10caf613'
- '66d87fec0d6f330ba518cd7d97abaeeb6fb2c2f3232fb7229d13264a54aeaa15')
+ '66d87fec0d6f330ba518cd7d97abaeeb6fb2c2f3232fb7229d13264a54aeaa15'
+ '894f4caf2a440d193e3c411142d92e956df6db8362709c178a88e791e6399192')
pkgver() {
cd ${_pkgname}
diff --git a/linux-get-scroll-info.patch b/linux-get-scroll-info.patch
new file mode 100644
index 000000000000..c9b5659695f6
--- /dev/null
+++ b/linux-get-scroll-info.patch
@@ -0,0 +1,21 @@
+diff --git a/ReClass.NET/UI/ScrollableCustomControl.cs b/ReClass.NET/UI/ScrollableCustomControl.cs
+index 4de6a4d..e5c05b7 100644
+--- a/ReClass.NET/UI/ScrollableCustomControl.cs
++++ b/ReClass.NET/UI/ScrollableCustomControl.cs
+@@ -2,6 +2,7 @@
+ using System.Diagnostics.Contracts;
+ using System.Runtime.InteropServices;
+ using System.Windows.Forms;
++using ReClassNET.Native;
+
+ namespace ReClassNET.UI
+ {
+@@ -213,7 +214,7 @@ namespace ReClassNET.UI
+ case ScrollEventType.ThumbTrack:
+ case ScrollEventType.ThumbPosition:
+
+- if (GetScrollInfo(new HandleRef(this, Handle), bar, scrollinfo))
++ if (!NativeMethods.IsUnix() && GetScrollInfo(new HandleRef(this, Handle), bar, scrollinfo))
+ {
+ SetValue(type, scrollProperties, scrollinfo.nTrackPos);
+ }