summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormakikatze2018-11-26 11:40:49 +0100
committermakikatze2018-11-26 11:40:49 +0100
commitd2a0590e7677b9c7d13f88c6b1f0b21c9a024c00 (patch)
tree8a967d2d94859795be9f48fce50f5641a89f55d0
downloadaur-d2a0590e7677b9c7d13f88c6b1f0b21c9a024c00.tar.gz
Initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9a31ee7b3da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = recordurbate
+ pkgdesc = A Bot to automatically record Chaturbate live streams
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/maki-chan/Recordurbate
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = youtube-dl
+ depends = ffmpeg
+ source = git+https://github.com/maki-chan/Recordurbate.git#tag=1.2.0
+ sha256sums = SKIP
+
+pkgname = recordurbate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17ecd8e1f70f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michael Armbruster <michael@armbrust.me>
+pkgname=recordurbate
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A Bot to automatically record Chaturbate live streams"
+url="https://github.com/maki-chan/Recordurbate"
+arch=('any')
+license=('GPL3')
+depends=('python' 'youtube-dl' 'ffmpeg')
+makedepends=('git')
+source=("git+https://github.com/maki-chan/Recordurbate.git#tag=1.2.0")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "Recordurbate"
+ git describe --tags --abbrev=0 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "Recordurbate"
+ python setup.py build
+}
+
+package() {
+ cd "Recordurbate"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}