summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuki Ibe2021-03-17 20:19:22 +0900
committerYuki Ibe2021-03-17 20:19:22 +0900
commita5c4abfbac20892214cba38f2c5a51a5317e34a1 (patch)
tree50abacbfc2e67b6173dae1edbb1cd5e5f7ea4886
parent0de0ff426636b6d931ae9b131fb15da0740cf111 (diff)
downloadaur-a5c4abfbac20892214cba38f2c5a51a5317e34a1.tar.gz
Fork recutils package into recutils-git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 41 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 483259a3d99d..cc2463cd46e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
-pkgbase = recutils
+pkgbase = recutils-git
pkgdesc = Set of tools and libraries to access plain text databases called recfiles.
- pkgver = 1.8
- pkgrel = 3
+ pkgver = 1.8.r26.gea03fda
+ pkgrel = 1
url = https://www.gnu.org/software/recutils/
arch = i686
arch = x86_64
license = GPL
checkdepends = check
+ makedepends = git
+ makedepends = help2man
+ makedepends = rsync
+ depends = curl
depends = libgcrypt
- source = https://ftp.gnu.org/gnu/recutils/recutils-1.8.tar.gz
- source = https://ftp.gnu.org/gnu/recutils/recutils-1.8.tar.gz.sig
- validpgpkeys = BDFA5717FC1DD35C2C3832A23EF90523B304AF08
- sha256sums = df8eae69593fdba53e264cbf4b2307dfb82120c09b6fab23e2dad51a89a5b193
+ provides = recutils
+ conflicts = recutils
+ source = git+https://git.savannah.gnu.org/git/recutils.git
+ source = git+https://git.savannah.gnu.org/git/gnulib.git
+ sha256sums = SKIP
sha256sums = SKIP
-pkgname = recutils
+pkgname = recutils-git
diff --git a/PKGBUILD b/PKGBUILD
index 1156df48e0fe..6a60644c3404 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,50 @@
-# Maintainer: Stefan Haller <fgrsnau@gmail.com>
-pkgname=recutils
-pkgver=1.8
-pkgrel=3
+# Maintainer: Yuki Ibe <yibe\100yibe\056org>
+# Based on recutils package (https://aur.archlinux.org/packages/recutils/)
+pkgname=recutils-git
+pkgver=1.8.r26.gea03fda
+pkgrel=1
pkgdesc="Set of tools and libraries to access plain text databases called recfiles."
arch=(i686 x86_64)
url="https://www.gnu.org/software/recutils/"
license=('GPL')
-depends=('libgcrypt')
+depends=('curl' 'libgcrypt')
+makedepends=('git' 'help2man' 'rsync')
checkdepends=('check')
-# Jose E. Marchesi <jemarch.at.gnu.org>
-validpgpkeys=("BDFA5717FC1DD35C2C3832A23EF90523B304AF08")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=(
- "https://ftp.gnu.org/gnu/recutils/$pkgname-$pkgver.tar.gz"
- "https://ftp.gnu.org/gnu/recutils/$pkgname-$pkgver.tar.gz.sig"
+ "git+https://git.savannah.gnu.org/git/recutils.git"
+ "git+https://git.savannah.gnu.org/git/gnulib.git"
)
sha256sums=(
- 'df8eae69593fdba53e264cbf4b2307dfb82120c09b6fab23e2dad51a89a5b193'
- 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
+prepare() {
+ cd "${pkgname%-git}"
+ git config submodule.gnulib.url ../gnulib
+ git submodule update gnulib
+ ./bootstrap
+}
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname%-git}"
./configure --prefix=/usr
make
}
check() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname%-git}"
make -k check
}
package() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname%-git}"
make DESTDIR="$pkgdir/" install
}