summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2023-09-11 19:07:37 -0700
committerDonald Webster2023-09-11 20:51:06 -0700
commit57b5acea3c37086f4af59b68bb522d16e421806b (patch)
tree941f38b354e9af875e5fee5b6b09cc93e8559369
downloadaur-57b5acea3c37086f4af59b68bb522d16e421806b.tar.gz
Initial version of recyclarr package.
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD52
-rw-r--r--recyclarr.service16
-rw-r--r--recyclarr.sysusers1
-rw-r--r--recyclarr.timer10
-rw-r--r--recyclarr.tmpfiles5
-rw-r--r--recyclarr.yml75
8 files changed, 196 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe6bf14b9cd3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = recyclarr
+ pkgdesc = A command-line application that will automatically synchronize recommended settings from the TRaSH guides to your Sonarr/Radarr instances.
+ pkgver = 5.4.0
+ pkgrel = 1
+ url = https://github.com/recyclarr/recyclarr
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = MIT
+ optdepends = sonarr: Movie download automation for usenet and torrents.
+ optdepends = radarr: TV download automation for usenet and torrents.
+ options = !strip
+ options = staticlibs
+ backup = etc/recyclarr/recyclarr.yml
+ source = recyclarr.service
+ source = recyclarr.timer
+ source = recyclarr.tmpfiles
+ source = recyclarr.sysusers
+ source = recyclarr.yml
+ sha512sums = 1c8f24a19c89efb775c5f3d212235b36cb1fc5cb93b1af9c716965f570836d1d4b9888be69227629297f5e416d5271b83eb5fcb170ee3d4e6f56912b692e692c
+ sha512sums = e6c6714cf82038b700421b17c96293a1cc045374c2efb3abd5d9f78c16e3e1a1b6f3858b10d07363381d137a09de242a639a084eee24a3f18fe1bd3b97cd5e48
+ sha512sums = b26a7ebfe04bb6d15f94a423e844a546df7e3f767ecef0a39a74bc6affdb99a897075b2ef3e05c5514800d6e0f5f5afe02a9003852defc0091328171d9ebc3c1
+ sha512sums = 3eb0acff87af1553508c5da080a6767f204868dc33a6a5f2253d25164052ab8ba96f89c88ad4bb82227a0f3b7e172f692abfe84d3e9a800448b8f7e194304978
+ sha512sums = 87a9430a2dd4d14de36af0697342d7482585839b8ab66f8fa8da61f8965e145472554ba966a9d97692cf14332dd6fdb3a36d5daff14c1c868b7e6779c5d65c23
+ source_x86_64 = recyclarr.5.4.0.linux-x64.tar.gz::https://github.com/recyclarr/recyclarr/releases/download/v5.4.0/recyclarr-linux-x64.tar.xz
+ sha512sums_x86_64 = 92e5ab092c2866cf9bb2edd32fb7487a2149c0925176e089e208260f48e8f440aee856dd9679cb5db13ed4e0391b83f61cef9a24b893a58ab3b342cd9f26ab91
+ source_aarch64 = recyclarr.5.4.0.linux-arm64.tar.gz::https://github.com/recyclarr/recyclarr/releases/download/v5.4.0/recyclarr-linux-arm64.tar.xz
+ sha512sums_aarch64 = b7910d2bf44c8909af204a2dcbf1ec129d0636f620ff6cd22a7b401b9dc22f753891a9bd6ef40608cf411e6207802d6285d151cc5b1dbbd35ca9b9d163eda7a6
+ source_armv7h = recyclarr.nightly.5.4.0.linux-arm.tar.gz::https://github.com/recyclarr/recyclarr/releases/download/v5.4.0/recyclarr-linux-arm.tar.xz
+ sha512sums_armv7h = 519231a286113d024fdf0d84abaf27af4f53a7a4e2cb36de122a0da2db0aaf1e499559e5524f5d827e118345dfd9ea175535a48d9b09ad62c7e5af1d8341c3db
+
+pkgname = recyclarr
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e570bc49abe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.gz
+*.log
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45c0facbbae3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Donald Webster <fryfrog@gmail.com>
+
+pkgname="recyclarr"
+pkgver=5.4.0
+pkgrel=1
+pkgdesc="A command-line application that will automatically synchronize recommended settings from the TRaSH guides to your Sonarr/Radarr instances."
+arch=('x86_64' 'aarch64' 'armv7h')
+url="https://github.com/recyclarr/recyclarr"
+license=('MIT')
+options=('!strip' 'staticlibs')
+optdepends=(
+ 'sonarr: Movie download automation for usenet and torrents.'
+ 'radarr: TV download automation for usenet and torrents.'
+)
+
+backup=('etc/recyclarr/recyclarr.yml')
+
+source_x86_64=("recyclarr.${pkgver}.linux-x64.tar.gz::https://github.com/recyclarr/recyclarr/releases/download/v${pkgver}/recyclarr-linux-x64.tar.xz")
+source_aarch64=("recyclarr.${pkgver}.linux-arm64.tar.gz::https://github.com/recyclarr/recyclarr/releases/download/v${pkgver}/recyclarr-linux-arm64.tar.xz")
+source_armv7h=("recyclarr.nightly.${pkgver}.linux-arm.tar.gz::https://github.com/recyclarr/recyclarr/releases/download/v5.4.0/recyclarr-linux-arm.tar.xz")
+
+source=(
+ 'recyclarr.service'
+ 'recyclarr.timer'
+ 'recyclarr.tmpfiles'
+ 'recyclarr.sysusers'
+ 'recyclarr.yml'
+)
+sha512sums=('1c8f24a19c89efb775c5f3d212235b36cb1fc5cb93b1af9c716965f570836d1d4b9888be69227629297f5e416d5271b83eb5fcb170ee3d4e6f56912b692e692c'
+ 'e6c6714cf82038b700421b17c96293a1cc045374c2efb3abd5d9f78c16e3e1a1b6f3858b10d07363381d137a09de242a639a084eee24a3f18fe1bd3b97cd5e48'
+ 'b26a7ebfe04bb6d15f94a423e844a546df7e3f767ecef0a39a74bc6affdb99a897075b2ef3e05c5514800d6e0f5f5afe02a9003852defc0091328171d9ebc3c1'
+ '3eb0acff87af1553508c5da080a6767f204868dc33a6a5f2253d25164052ab8ba96f89c88ad4bb82227a0f3b7e172f692abfe84d3e9a800448b8f7e194304978'
+ '87a9430a2dd4d14de36af0697342d7482585839b8ab66f8fa8da61f8965e145472554ba966a9d97692cf14332dd6fdb3a36d5daff14c1c868b7e6779c5d65c23')
+sha512sums_x86_64=('92e5ab092c2866cf9bb2edd32fb7487a2149c0925176e089e208260f48e8f440aee856dd9679cb5db13ed4e0391b83f61cef9a24b893a58ab3b342cd9f26ab91')
+sha512sums_aarch64=('b7910d2bf44c8909af204a2dcbf1ec129d0636f620ff6cd22a7b401b9dc22f753891a9bd6ef40608cf411e6207802d6285d151cc5b1dbbd35ca9b9d163eda7a6')
+sha512sums_armv7h=('519231a286113d024fdf0d84abaf27af4f53a7a4e2cb36de122a0da2db0aaf1e499559e5524f5d827e118345dfd9ea175535a48d9b09ad62c7e5af1d8341c3db')
+
+
+
+package() {
+ install -D -m 755 "${srcdir}/recyclarr" "${pkgdir}/usr/bin/recyclarr"
+
+ mkdir -p "${pkgdir}/etc/recyclarr"
+ install -D -m 600 "${srcdir}/recyclarr.yml" "${pkgdir}/etc/recyclarr/recyclarr.yml"
+
+ mkdir -p "${pkgdir}/var/lib/recyclarr"
+
+ install -D -m 644 "${srcdir}/recyclarr.service" "${pkgdir}/usr/lib/systemd/system/recyclarr.service"
+ install -D -m 644 "${srcdir}/recyclarr.timer" "${pkgdir}/usr/lib/systemd/system/recyclarr.timer"
+ install -D -m 644 "${srcdir}/recyclarr.sysusers" "${pkgdir}/usr/lib/sysusers.d/recyclarr.conf"
+ install -D -m 644 "${srcdir}/recyclarr.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/recyclarr.conf"
+}
diff --git a/recyclarr.service b/recyclarr.service
new file mode 100644
index 000000000000..35042a740db1
--- /dev/null
+++ b/recyclarr.service
@@ -0,0 +1,16 @@
+# Be sure to use `systemctl edit recyclarr` to modify this service with an override.conf because
+# direct changes will be overwritten by package updates.
+
+[Unit]
+Description=recyclarr sync
+ConditionPathExists=/etc/recyclarr/recyclarr.yml
+
+[Service]
+User=recyclarr
+Group=recyclarr
+SyslogIdentifier=recyclarr
+ExecStart=/usr/bin/recyclarr sync --config /etc/recyclarr/recyclarr.yml
+Type=oneshot
+
+[Install]
+WantedBy=multi-user.target
diff --git a/recyclarr.sysusers b/recyclarr.sysusers
new file mode 100644
index 000000000000..51b8d92009f4
--- /dev/null
+++ b/recyclarr.sysusers
@@ -0,0 +1 @@
+u recyclarr - "recyclarr daemon" /var/lib/recyclarr
diff --git a/recyclarr.timer b/recyclarr.timer
new file mode 100644
index 000000000000..f9b088f84028
--- /dev/null
+++ b/recyclarr.timer
@@ -0,0 +1,10 @@
+[Unit]
+Description=Daily recyclarr sync
+
+[Timer]
+OnCalendar=daily
+RandomizedDelaySec=360min
+Persistent=true
+
+[Install]
+WantedBy=timers.target
diff --git a/recyclarr.tmpfiles b/recyclarr.tmpfiles
new file mode 100644
index 000000000000..c89379dee609
--- /dev/null
+++ b/recyclarr.tmpfiles
@@ -0,0 +1,5 @@
+# Override this file with a modified version in /etc/tmpfiles.d/
+d /etc/recyclarr 0755 recyclarr recyclarr
+Z /etc/recyclarr - recyclarr recyclarr
+d /var/lib/recyclarr 0755 recyclarr recyclarr
+Z /var/lib/recyclarr - recyclarr recyclarr
diff --git a/recyclarr.yml b/recyclarr.yml
new file mode 100644
index 000000000000..ad6a26f6ce28
--- /dev/null
+++ b/recyclarr.yml
@@ -0,0 +1,75 @@
+# yaml-language-server: $schema=https://raw.githubusercontent.com/recyclarr/recyclarr/master/schemas/config-schema.json
+
+# A starter config to use with Recyclarr. Most values are set to "reasonable defaults". Update the
+# values below as needed for your instance. You will be required to update the API Key and URL for
+# each instance you want to use.
+#
+# Many optional settings have been omitted to keep this template simple. Note that there's no "one
+# size fits all" configuration. Please refer to the guide to understand how to build the appropriate
+# configuration based on your hardware setup and capabilities.
+#
+# For any lines that mention uncommenting YAML, you simply need to remove the leading hash (`#`).
+# The YAML comments will already be at the appropriate indentation.
+#
+# For more details on the configuration, see the Configuration Reference on the wiki here:
+# https://recyclarr.dev/wiki/yaml/config-reference/
+
+# Configuration specific to Sonarr
+sonarr:
+ series:
+ # Set the URL/API Key to your actual instance
+ base_url: http://localhost:8989
+ api_key: YOUR_KEY_HERE
+
+ # Quality definitions from the guide to sync to Sonarr. Choices: series, anime
+ quality_definition:
+ type: series
+
+ # Release profiles from the guide to sync to Sonarr v3 (Sonarr v4 does not use this!)
+ # Use `recyclarr list release-profiles` for values you can put here.
+ # https://trash-guides.info/Sonarr/Sonarr-Release-Profile-RegEx/
+ release_profiles:
+ # Series
+ - trash_ids:
+ - EBC725268D687D588A20CBC5F97E538B # Low Quality Groups
+ - 1B018E0C53EC825085DD911102E2CA36 # Release Sources (Streaming Service)
+ - 71899E6C303A07AF0E4746EFF9873532 # P2P Groups + Repack/Proper
+ # Anime (Uncomment below if you want it)
+ #- trash_ids:
+ # - d428eda85af1df8904b4bbe4fc2f537c # Anime - First release profile
+ # - 6cd9e10bb5bb4c63d2d7cd3279924c7b # Anime - Second release profile
+
+# Configuration specific to Radarr.
+radarr:
+ movies:
+ # Set the URL/API Key to your actual instance
+ base_url: http://localhost:7878
+ api_key: YOUR_KEY_HERE
+
+ # Which quality definition in the guide to sync to Radarr. Only choice right now is 'movie'
+ quality_definition:
+ type: movie
+
+ # Set to 'true' to automatically remove custom formats from Radarr when they are removed from
+ # the guide or your configuration. This will NEVER delete custom formats you manually created!
+ delete_old_custom_formats: false
+
+ custom_formats:
+ # A list of custom formats to sync to Radarr.
+ # Use `recyclarr list custom-formats radarr` for values you can put here.
+ # https://trash-guides.info/Radarr/Radarr-collection-of-custom-formats/
+ - trash_ids:
+ - ed38b889b31be83fda192888e2286d83 # BR-DISK
+ - 90cedc1fea7ea5d11298bebd3d1d3223 # EVO (no WEBDL)
+ - 90a6f9a284dff5103f6346090e6280c8 # LQ
+ - dc98083864ea246d05a42df0d05f81cc # x265 (720/1080p)
+ - b8cd450cbfa689c0259a01d9e29ba3d6 # 3D
+
+ # Uncomment the below properties to specify one or more quality profiles that should be
+ # updated with scores from the guide for each custom format. Without this, custom formats
+ # are synced to Radarr but no scores are set in any quality profiles.
+ #quality_profiles:
+ # - name: Quality Profile 1
+ # - name: Quality Profile 2
+ # #score: -9999 # Optional score to assign to all CFs. Overrides scores in the guide.
+ # #reset_unmatched_scores: true # Optionally set other scores to 0 if they are not listed in 'names' above.