summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohnpyp2021-09-01 22:16:32 -0400
committerjohnpyp2021-09-01 22:16:32 -0400
commit681639f2c253341f03af1757c91e9ea63de91e68 (patch)
tree7de1e97c79a8c72681b5e6f27e03cf8c1576caec
parent1d1dd6b424af857b6f87ef1371f2085ea2f5395c (diff)
downloadaur-681639f2c253341f03af1757c91e9ea63de91e68.tar.gz
Update to 0.16.0 and add icon
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD11
-rw-r--r--redact.desktop7
4 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17df651d78db..afda456fafb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = redact-bin
pkgdesc = Customize Redact to remove the content you'd like. Remove old tweets, images, discord messages, and much more.
- pkgver = 0.13.0
+ pkgver = 0.16.0
pkgrel = 1
url = https://redact.dev/
arch = x86_64
license = custom
provides = redact
conflicts = redact
- source = https://electron-release.redact.dev/build/Redact-0.13.0.zip
+ source = https://update-desktop.redact.dev/build/Redact-0.16.0.zip
source = redact.desktop
- sha256sums = 272979886a6ff6e7b3cfb5cd7b44dab5974c1f639522e5cad5ae234cfe5132b2
- sha256sums = 9316d86af16819bd94452e0184830e92fbb497e123fa3f8df00811e4b9861e41
+ sha256sums = 55a3b62ebc49a4417054d1f86345ecea3eaf7bf55e441dbb13e961532c674e2f
+ sha256sums = a05e8dd421979d3342dfaa011129ef3fdf0905b6bcf26646c687a3b63504081b
pkgname = redact-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..19e1071f0422
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+
+!/PKGBUILD
+!/redact.desktop
+!/.SRCINFO
+!/.gitignore
+
diff --git a/PKGBUILD b/PKGBUILD
index ee50aa66a206..164841e3814e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Alexander Björk <bjorkalx@protonmail.com>
+# Maintainer: johnpyp <johnpyp.dev@gmail.com>
pkgname="redact-bin"
pkgdesc="Customize Redact to remove the content you'd like. Remove old tweets, images, discord messages, and much more."
-pkgver="0.13.0"
+pkgver="0.16.0"
pkgrel=1
arch=('x86_64')
url="https://redact.dev/"
license=('custom')
provides=('redact')
conflicts=('redact')
-source=("https://electron-release.redact.dev/build/Redact-${pkgver}.zip"
+source=("https://update-desktop.redact.dev/build/Redact-${pkgver}.zip"
"redact.desktop")
-sha256sums=('272979886a6ff6e7b3cfb5cd7b44dab5974c1f639522e5cad5ae234cfe5132b2'
- '9316d86af16819bd94452e0184830e92fbb497e123fa3f8df00811e4b9861e41')
+sha256sums=('55a3b62ebc49a4417054d1f86345ecea3eaf7bf55e441dbb13e961532c674e2f'
+ 'a05e8dd421979d3342dfaa011129ef3fdf0905b6bcf26646c687a3b63504081b')
package() {
@@ -22,4 +23,6 @@ package() {
install -d ${pkgdir}/usr/bin
ln -s /opt/${pkgname}/redact ${pkgdir}/usr/bin/redact
install -Dm644 "${srcdir}/redact.desktop" "${pkgdir}/usr/share/applications/redact.desktop"
+ mkdir -p "${pkgdir}/usr/share/pixmaps"
+ ln -s /opt/${pkgname}/resources/assets/icon.png "${pkgdir}/usr/share/pixmaps/redact.png"
}
diff --git a/redact.desktop b/redact.desktop
index 49fa958b0162..a6478c153db5 100644
--- a/redact.desktop
+++ b/redact.desktop
@@ -1,9 +1,10 @@
[Desktop Entry]
Name=Redact
-StartupWMClass=Redact
-Exec=/usr/bin/redact
+Exec=/usr/bin/redact %U
+Terminal=false
Type=Application
Icon=redact
-Comment=Redact your history
+StartupWMClass=Redact
+Comment=Mass delete your social media history
Categories=Utility;
Path=/usr/bin