summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphiresky2017-04-03 02:20:42 +0200
committerphiresky2017-04-03 02:20:51 +0200
commitabc87fde63d0e3560ef837021ea716339ef68938 (patch)
tree9cbd115a027d88a249752e7e42b1e93594be6d6f
parent615755e1726b4c77f4cff0ecc729399d0083372b (diff)
downloadaur-abc87fde63d0e3560ef837021ea716339ef68938.tar.gz
update
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD1
-rw-r--r--reddit-placebot.install19
3 files changed, 20 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70d318df59db..0b431253153d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Apr 3 00:13:48 UTC 2017
+# Mon Apr 3 00:20:44 UTC 2017
pkgbase = reddit-placebot
pkgdesc = Automatically place pixels on reddit.com/r/place (not working yet, needs patches)
pkgver = r18.c8fcbfb
diff --git a/PKGBUILD b/PKGBUILD
index a7234fd34c08..8d797a5003ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,6 +33,7 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
+ git checkout service
# git checkout "tags/$(git describe --tags --abbrev=0)"
}
diff --git a/reddit-placebot.install b/reddit-placebot.install
index 532c0aac7386..b261d097dddd 100644
--- a/reddit-placebot.install
+++ b/reddit-placebot.install
@@ -1,3 +1,20 @@
post_install() {
- echo "start using 'systemctl --user start reddit-placebot'"
+ cat <<EOF
+Create a file users.json in ~/.config/reddit-placebot/users.json as follows:
+
+{
+ "YourRedditUserName": "YourRedditPassword",
+ "OtherAccount": "OtherPassword",
+ "MoreThrowaways": "MorePasswords"
+}
+
+then start the service using
+
+ systemctl --user start reddit-placebot
+
+and monitor the output using
+
+ journalctl --user --follow --unit reddit-placebot
+EOF
+
}