summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarl.george2015-06-08 18:49:12 -0500
committercarl.george2015-06-08 18:49:12 -0500
commit838068a7a229f4185ff0252771bc173ea5ea3de0 (patch)
treeaa71f3b39cdee6ba40abc9288ba53a221c30b611
downloadaur-838068a7a229f4185ff0252771bc173ea5ea3de0.tar.gz
1.5.1-2
-rw-r--r--.SRCINFO29
-rw-r--r--0e67905e42fae53e7d1f377fe8cd7e6a88f3cbb9.patch84
-rw-r--r--PKGBUILD40
-rw-r--r--redeclipse.install11
4 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94938d4c68a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = redeclipse
+ pkgdesc = free, casual arena shooter
+ pkgver = 1.5.1
+ pkgrel = 2
+ url = http://redeclipse.net
+ install = redeclipse.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ license = CC0
+ license = CCPL:by
+ license = CCPL:by-sa
+ license = ZLIB
+ license = MIT
+ makedepends = ed
+ depends = sdl_image
+ depends = libgl
+ depends = sdl_mixer
+ depends = hicolor-icon-theme
+ depends = glu
+ source = base-1.5.1.tar.gz::https://github.com/red-eclipse/base/archive/v1.5.1.tar.gz
+ source = data-1.5.1.tar.gz::https://github.com/red-eclipse/data/archive/v1.5.1.tar.gz
+ source = 0e67905e42fae53e7d1f377fe8cd7e6a88f3cbb9.patch
+ sha256sums = 2982c4337f4b344c6d77def6b2baec3a2b99b70a88752137475845f95c4d5193
+ sha256sums = eba632f57b4fa76d6701950907231b354398883613da36c17dbc062c1758dd37
+ sha256sums = 390e51b2a4fe73da94a044ed46f03ca7257335e5bef021eb1b1bf73bb4236cc1
+
+pkgname = redeclipse
+
diff --git a/0e67905e42fae53e7d1f377fe8cd7e6a88f3cbb9.patch b/0e67905e42fae53e7d1f377fe8cd7e6a88f3cbb9.patch
new file mode 100644
index 000000000000..875ecfdcc6b3
--- /dev/null
+++ b/0e67905e42fae53e7d1f377fe8cd7e6a88f3cbb9.patch
@@ -0,0 +1,84 @@
+From 0e67905e42fae53e7d1f377fe8cd7e6a88f3cbb9 Mon Sep 17 00:00:00 2001
+From: Martin Erik Werner <martinerikwerner@gmail.com>
+Date: Fri, 3 Apr 2015 11:23:59 +0200
+Subject: [PATCH] system-install: Add common install target for common config
+
+version.cfg is needed by both client and server, in order to cater to
+this the simplest solution seems to be to stuff the whole config dir in
+a common install target (instead of picking out the version.cfg file
+specifically, and mess with exclusion when handling the config dir in
+other targets). In distro packaging, this might make a separate package.
+---
+ src/system-install.mk | 24 +++++++++++++++---------
+ 1 file changed, 15 insertions(+), 9 deletions(-)
+
+diff --git a/src/system-install.mk b/src/system-install.mk
+index e6eae10..1f0b1cd 100644
+--- a/src/system-install.mk
++++ b/src/system-install.mk
+@@ -55,6 +55,7 @@ icons: $(ICONS)
+ system-install-client: client
+ $(MKDIR) $(libexecdir)/$(appname)
+ $(MKDIR) $(gamesbindir)
++ $(MKDIR) $(datadir)/$(appname)
+ install -m755 $(appclient) $(libexecdir)/$(appname)/$(appname)
+ install -m755 install/nix/$(appsrcname).am \
+ $(gamesbindir)/$(appname)
+@@ -89,14 +90,17 @@ system-install-server: server
+ g,@APPNAME@,\
+ s,@APPNAME@,$(appname),g\n\
+ w\n" | ed -s $(gamesbindir)/$(appname)-server
+- install -m644 ../config/version.cfg \
+- $(datadir)/$(appname)/version.cfg
+- ln -s $(patsubst $(DESTDIR)%,%,$(datadir))/$(appname)/version.cfg \
+- $(libexecdir)/$(appname)/version.cfg
++
++system-install-common:
++ $(MKDIR) $(libexecdir)/$(appname)
++ $(MKDIR) $(datadir)/$(appname)
++ cp -r ../config $(datadir)/$(appname)/config
++ ln -s $(patsubst $(DESTDIR)%,%,$(datadir))/$(appname)/config \
++ $(libexecdir)/$(appname)/config
+
+ system-install-data:
++ $(MKDIR) $(datadir)/$(appname)
+ cp -r ../data $(datadir)/$(appname)/data
+- rm -f $(datadir)/$(appname)/data/misc/largeandincharge.png
+
+ system-install-docs: $(MANPAGES)
+ $(MKDIR) $(mandir)/man6
+@@ -154,12 +158,15 @@ system-install-cube2font-docs: ../doc/man/cube2font.1
+ gzip -9 -n -c < ../doc/man/cube2font.1 \
+ > $(mandir)/man1/cube2font.1.gz
+
+-system-install: system-install-client system-install-server system-install-data system-install-docs system-install-menus
++system-install: system-install-client system-install-server system-install-common system-install-data system-install-docs system-install-menus
++
++system-uninstall-common:
++ rm -rf $(datadir)/$(appname)/config
++ @rm -fv $(libexecdir)/$(appname)/config
+
+ system-uninstall-client:
+ @rm -fv $(libexecdir)/$(appname)/$(appname)
+ @rm -fv $(libexecdir)/$(appname)/data
+- @rm -fv $(libexecdir)/$(appname)/version.cfg
+ @rm -fv $(gamesbindir)/$(appname)
+
+ system-uninstall-server:
+@@ -168,7 +175,6 @@ system-uninstall-server:
+
+ system-uninstall-data:
+ rm -rf $(datadir)/$(appname)/data
+- rm -fv $(datadir)/$(appname)/version.cfg
+
+ system-uninstall-docs:
+ @rm -rfv $(docdir)/$(appname)/examples
+@@ -185,7 +191,7 @@ system-uninstall-menus:
+ @rm -fv $(icondir)/128x128/apps/$(appname).png
+ @rm -fv $(pixmapdir)/$(appname).xpm
+
+-system-uninstall: system-uninstall-client system-uninstall-server system-uninstall-data system-uninstall-docs system-uninstall-menus
++system-uninstall: system-uninstall-client system-uninstall-server system-uninstall-common system-uninstall-data system-uninstall-docs system-uninstall-menus
+ -@rmdir -v $(libexecdir)/$(appname)
+ -@rmdir -v $(datadir)/$(appname)
+ -@rmdir -v $(docdir)/$(appname)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89686b89da61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Carl George < arch at cgtx dot us >
+# Contributor: Zohar Malamant <dotfloat gmail com>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Martin Erik Werner ("arand") <martinerikwerner@gmail.com>
+
+pkgname="redeclipse"
+pkgver="1.5.1"
+pkgrel="2"
+pkgdesc="free, casual arena shooter"
+arch=("i686" "x86_64")
+url="http://redeclipse.net"
+license=("custom" "CC0" "CCPL:by" "CCPL:by-sa" "ZLIB" "MIT")
+makedepends=("ed")
+depends=("sdl_image" "libgl" "sdl_mixer" "hicolor-icon-theme" "glu")
+install="redeclipse.install"
+source=("base-${pkgver}.tar.gz::https://github.com/red-eclipse/base/archive/v${pkgver}.tar.gz"
+ "data-${pkgver}.tar.gz::https://github.com/red-eclipse/data/archive/v${pkgver}.tar.gz"
+ "0e67905e42fae53e7d1f377fe8cd7e6a88f3cbb9.patch")
+sha256sums=('2982c4337f4b344c6d77def6b2baec3a2b99b70a88752137475845f95c4d5193'
+ 'eba632f57b4fa76d6701950907231b354398883613da36c17dbc062c1758dd37'
+ '390e51b2a4fe73da94a044ed46f03ca7257335e5bef021eb1b1bf73bb4236cc1')
+
+prepare() {
+ cd "${srcdir}/base-${pkgver}"
+ rmdir data
+ mv "${srcdir}/data-${pkgver}" data
+ patch -p1 -i "${srcdir}/0e67905e42fae53e7d1f377fe8cd7e6a88f3cbb9.patch"
+}
+
+build() {
+ cd "${srcdir}/base-${pkgver}"
+ make -C src/ client server
+}
+
+package() {
+ cd "${srcdir}/base-${pkgver}"
+ make -C src/ DESTDIR="${pkgdir}" prefix=/usr system-install
+ install -Dm 0644 "${srcdir}/base-${pkgver}/doc/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+ install -Dm 0644 "${srcdir}/base-${pkgver}/doc/all-licenses.txt" "${pkgdir}/usr/share/licenses/${pkgname}/all-licenses.txt"
+}
diff --git a/redeclipse.install b/redeclipse.install
new file mode 100644
index 000000000000..d448371338f2
--- /dev/null
+++ b/redeclipse.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}