summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordevninja2016-01-28 11:04:37 -0500
committerdevninja2016-01-28 11:04:37 -0500
commitd7a0cbddcbf8a1c29d99ad4a1dec60de9e081a09 (patch)
treee4f72acddf29e3418b59052fdd58da46170d14ba
downloadaur-d7a0cbddcbf8a1c29d99ad4a1dec60de9e081a09.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41dd72a39393
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Jan 28 16:04:32 UTC 2016
+pkgbase = redfang
+ pkgdesc = Redfang v2.5 is an enhanced version of the original application that finds non-discoverable Bluetooth devices by brute-forcing the last six bytes of the device's Bluetooth address and doing a read_remote_name().
+ pkgver = 2.5
+ pkgrel = 1
+ url = http://packetstormsecurity.com/files/31864/redfang.2.5.tar.gz.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gcc
+ depends = bluez-libs
+ source = http://dl.packetstormsecurity.net/wireless/redfang.2.5.tar.gz
+ sha256sums = 7cf45008810ca894b085ae0eb1a0071f0cb6989dd9ce35cfcd617fedf7018c7f
+
+pkgname = redfang
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01c7514a746d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# past-Maintainer: Ryon Sherman <ryon.sherman@gmail.com>
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+
+_pkgid=31864
+
+pkgname=redfang
+pkgver=2.5
+pkgrel=1
+pkgdesc="Redfang v2.5 is an enhanced version of the original application that finds non-discoverable Bluetooth devices by brute-forcing the last six bytes of the device's Bluetooth address and doing a read_remote_name()."
+
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://packetstormsecurity.com/files/${_pkgid}/${pkgname}.${pkgver}.tar.gz.html"
+
+depends=('bluez-libs')
+makedepends=('gcc')
+source=("http://dl.packetstormsecurity.net/wireless/${pkgname}.${pkgver}.tar.gz")
+sha256sums=('7cf45008810ca894b085ae0eb1a0071f0cb6989dd9ce35cfcd617fedf7018c7f')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ sed -i '1i#include <linux/limits.h>' fang.c
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ install -d ${pkgdir}/usr/{bin,share/licenses/${pkgname}}
+ install -Dm0755 fang ${pkgdir}/usr/bin/${pkgname}
+ install -Dm0644 README ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}