summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJocadbz2022-06-10 19:35:58 -0300
committerJocadbz2022-06-10 19:35:58 -0300
commit17daeb7c0574dd7c069a2c334b45e7c311568a8a (patch)
treeafea88e6dca5bde2f81045a4bd04576b065623fe
downloadaur-17daeb7c0574dd7c069a2c334b45e7c311568a8a.tar.gz
Initial commit of redfetch-git package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d900d9ead1ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = redfetch-git
+ pkgdesc = A fast fetch written in C, with the ppfetch Ascii Art.
+ pkgver = r0.ga0f9e6d
+ pkgrel = 1
+ url = https://github.com/RedsonBr140/Redfetch
+ arch = x86_64
+ license = MIT
+ makedepends = gcc
+ makedepends = make
+ makedepends = git
+ depends = wmctrl
+ provides = redfetch
+ source = redfetch::git+https://github.com/RedsonBr140/redfetch.git
+ sha256sums = SKIP
+
+pkgname = redfetch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e8407da7322
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jocadbz <madureirajoaquim95@gmail.com>
+# Maintainer: RedsonBr <redson@riseup.com>
+
+pkgname=redfetch-git
+_pkgname=redfetch
+pkgver=r0.ga0f9e6d
+pkgrel=1
+pkgdesc="A fast fetch written in C, with the ppfetch Ascii Art."
+arch=('x86_64')
+url="https://github.com/RedsonBr140/Redfetch"
+license=('MIT')
+makedepends=('gcc' 'make' 'git')
+depends=('wmctrl')
+provides=('redfetch')
+source=("$_pkgname::git+https://github.com/RedsonBr140/redfetch.git")
+sha256sums=('SKIP') # We can't verify the git build every time
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 redfetch "$pkgdir/usr/bin/redfetch"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}