summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Konovalov2018-02-22 09:27:59 +0500
committerVyacheslav Konovalov2018-02-22 09:27:59 +0500
commit113a2beee854255dd53b82423c47531c46bc8457 (patch)
treecdd6f442b104e25ce4a152ea930e01595332868c
parent983c9d044c1b5b7d534821c4cfa98b2561e7f594 (diff)
downloadaur-113a2beee854255dd53b82423c47531c46bc8457.tar.gz
update to 0.9.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD5
-rw-r--r--fix.patch213
3 files changed, 4 insertions, 222 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60f8c5175f27..ccd78387a2fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 24 21:09:48 UTC 2017
+# Thu Feb 22 04:27:40 UTC 2018
pkgbase = redis-desktop-manager
pkgdesc = Open source cross-platform Redis Desktop Manager based on Qt 5
- pkgver = 0.9.0_alpha5
+ pkgver = 0.9.0
pkgrel = 1
url = https://redisdesktop.com/
arch = x86_64
@@ -19,12 +19,10 @@ pkgbase = redis-desktop-manager
depends = qt5-svg
depends = libssh2
conflicts = redis-desktop-manager-bin
- source = rdm::git://github.com/uglide/RedisDesktopManager.git#tag=0.9.0-alpha5
- source = fix.patch
+ source = rdm::git://github.com/uglide/RedisDesktopManager.git#tag=0.9.0
source = rdm.sh
source = rdm.desktop
sha256sums = SKIP
- sha256sums = a093ac27fb246422ff304e14a35c2b4c3869f1f6e3c6d0fdcbdaf37d867973cd
sha256sums = f469d9a5adce723904efe0f1b1db5d79807410f90aafb117f18ae108d8b2d391
sha256sums = 4fac85cec4a7abe7254ff3a6f0382d9a6f2b712372ecbd74474a2f8efe9c4e3c
diff --git a/PKGBUILD b/PKGBUILD
index 761b4968f913..67bcd130755a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vyacheslav Konovalov <echo dnlhY2hrb25vdmFsb3ZAZ21haWwuY29tCg== | base64 -d>
pkgname=redis-desktop-manager
-_pkgver=0.9.0-alpha5
+_pkgver=0.9.0
pkgver=${_pkgver/-/_}
pkgrel=1
pkgdesc='Open source cross-platform Redis Desktop Manager based on Qt 5'
@@ -12,11 +12,9 @@ depends=('qt5-base' 'qt5-charts' 'qt5-imageformats' 'qt5-tools' 'qt5-declarative
makedepends=('git' 'gcc')
conflicts=('redis-desktop-manager-bin')
source=("rdm::git://github.com/uglide/RedisDesktopManager.git#tag=${_pkgver}"
- 'fix.patch'
'rdm.sh'
'rdm.desktop')
sha256sums=('SKIP'
- 'a093ac27fb246422ff304e14a35c2b4c3869f1f6e3c6d0fdcbdaf37d867973cd'
'f469d9a5adce723904efe0f1b1db5d79807410f90aafb117f18ae108d8b2d391'
'4fac85cec4a7abe7254ff3a6f0382d9a6f2b712372ecbd74474a2f8efe9c4e3c')
@@ -24,7 +22,6 @@ prepare() {
cd rdm/
git submodule update --init --recursive
git submodule add https://chromium.googlesource.com/linux-syscall-support 3rdparty/linux-syscall-support
- git apply $srcdir/fix.patch
python2 build/utils/set_version.py "${_pkgver}" > src/version.h
python2 build/utils/set_version.py "${_pkgver}" > 3rdparty/crashreporter/src/version.h
diff --git a/fix.patch b/fix.patch
deleted file mode 100644
index a12e0d688dff..000000000000
--- a/fix.patch
+++ /dev/null
@@ -1,213 +0,0 @@
-diff --git a/3rdparty/gbreakpad/src/client/linux/dump_writer_common/ucontext_reader.cc b/3rdparty/gbreakpad/src/client/linux/dump_writer_common/ucontext_reader.cc
-index c80724d..93b4d9f 100644
---- a/3rdparty/gbreakpad/src/client/linux/dump_writer_common/ucontext_reader.cc
-+++ b/3rdparty/gbreakpad/src/client/linux/dump_writer_common/ucontext_reader.cc
-@@ -40,15 +40,15 @@ namespace google_breakpad {
-
- #if defined(__i386__)
-
--uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.gregs[REG_ESP];
- }
-
--uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.gregs[REG_EIP];
- }
-
--void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
-+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
- const struct _libc_fpstate* fp) {
- const greg_t* regs = uc->uc_mcontext.gregs;
-
-@@ -88,15 +88,15 @@ void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
-
- #elif defined(__x86_64)
-
--uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.gregs[REG_RSP];
- }
-
--uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.gregs[REG_RIP];
- }
-
--void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
-+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
- const struct _libc_fpstate* fpregs) {
- const greg_t* regs = uc->uc_mcontext.gregs;
-
-@@ -145,15 +145,15 @@ void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
-
- #elif defined(__ARM_EABI__)
-
--uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.arm_sp;
- }
-
--uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.arm_pc;
- }
-
--void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc) {
-+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc) {
- out->context_flags = MD_CONTEXT_ARM_FULL;
-
- out->iregs[0] = uc->uc_mcontext.arm_r0;
-@@ -184,15 +184,15 @@ void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc) {
-
- #elif defined(__aarch64__)
-
--uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.sp;
- }
-
--uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.pc;
- }
-
--void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
-+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
- const struct fpsimd_context* fpregs) {
- out->context_flags = MD_CONTEXT_ARM64_FULL;
-
-@@ -210,15 +210,15 @@ void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc,
-
- #elif defined(__mips__)
-
--uintptr_t UContextReader::GetStackPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetStackPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.gregs[MD_CONTEXT_MIPS_REG_SP];
- }
-
--uintptr_t UContextReader::GetInstructionPointer(const struct ucontext* uc) {
-+uintptr_t UContextReader::GetInstructionPointer(const ucontext_t* uc) {
- return uc->uc_mcontext.pc;
- }
-
--void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext *uc) {
-+void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc) {
- #if _MIPS_SIM == _ABI64
- out->context_flags = MD_CONTEXT_MIPS64_FULL;
- #elif _MIPS_SIM == _ABIO32
-diff --git a/3rdparty/gbreakpad/src/client/linux/dump_writer_common/ucontext_reader.h b/3rdparty/gbreakpad/src/client/linux/dump_writer_common/ucontext_reader.h
-index b6e77b4..2369a9a 100644
---- a/3rdparty/gbreakpad/src/client/linux/dump_writer_common/ucontext_reader.h
-+++ b/3rdparty/gbreakpad/src/client/linux/dump_writer_common/ucontext_reader.h
-@@ -41,21 +41,21 @@ namespace google_breakpad {
-
- // Wraps platform-dependent implementations of accessors to ucontext structs.
- struct UContextReader {
-- static uintptr_t GetStackPointer(const struct ucontext* uc);
-+ static uintptr_t GetStackPointer(const ucontext_t* uc);
-
-- static uintptr_t GetInstructionPointer(const struct ucontext* uc);
-+ static uintptr_t GetInstructionPointer(const ucontext_t* uc);
-
- // Juggle a arch-specific ucontext into a minidump format
- // out: the minidump structure
- // info: the collection of register structures.
- #if defined(__i386__) || defined(__x86_64)
-- static void FillCPUContext(RawContextCPU *out, const ucontext *uc,
-+ static void FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
- const struct _libc_fpstate* fp);
- #elif defined(__aarch64__)
-- static void FillCPUContext(RawContextCPU *out, const ucontext *uc,
-+ static void FillCPUContext(RawContextCPU *out, const ucontext_t *uc,
- const struct fpsimd_context* fpregs);
- #else
-- static void FillCPUContext(RawContextCPU *out, const ucontext *uc);
-+ static void FillCPUContext(RawContextCPU *out, const ucontext_t *uc);
- #endif
- };
-
-diff --git a/3rdparty/gbreakpad/src/client/linux/handler/exception_handler.cc b/3rdparty/gbreakpad/src/client/linux/handler/exception_handler.cc
-index d372a10..14b18be 100644
---- a/3rdparty/gbreakpad/src/client/linux/handler/exception_handler.cc
-+++ b/3rdparty/gbreakpad/src/client/linux/handler/exception_handler.cc
-@@ -439,9 +439,9 @@ bool ExceptionHandler::HandleSignal(int /*sig*/, siginfo_t* info, void* uc) {
- // Fill in all the holes in the struct to make Valgrind happy.
- memset(&g_crash_context_, 0, sizeof(g_crash_context_));
- memcpy(&g_crash_context_.siginfo, info, sizeof(siginfo_t));
-- memcpy(&g_crash_context_.context, uc, sizeof(struct ucontext));
-+ memcpy(&g_crash_context_.context, uc, sizeof(ucontext_t));
- #if defined(__aarch64__)
-- struct ucontext* uc_ptr = (struct ucontext*)uc;
-+ ucontext_t* uc_ptr = (ucontext_t*)uc;
- struct fpsimd_context* fp_ptr =
- (struct fpsimd_context*)&uc_ptr->uc_mcontext.__reserved;
- if (fp_ptr->head.magic == FPSIMD_MAGIC) {
-@@ -450,9 +450,9 @@ bool ExceptionHandler::HandleSignal(int /*sig*/, siginfo_t* info, void* uc) {
- }
- #elif !defined(__ARM_EABI__) && !defined(__mips__)
- // FP state is not part of user ABI on ARM Linux.
-- // In case of MIPS Linux FP state is already part of struct ucontext
-+ // In case of MIPS Linux FP state is already part of ucontext_t
- // and 'float_state' is not a member of CrashContext.
-- struct ucontext* uc_ptr = (struct ucontext*)uc;
-+ ucontext_t* uc_ptr = (ucontext_t*)uc;
- if (uc_ptr->uc_mcontext.fpregs) {
- memcpy(&g_crash_context_.float_state, uc_ptr->uc_mcontext.fpregs,
- sizeof(g_crash_context_.float_state));
-@@ -471,12 +471,13 @@ bool ExceptionHandler::HandleSignal(int /*sig*/, siginfo_t* info, void* uc) {
- // This is a public interface to HandleSignal that allows the client to
- // generate a crash dump. This function may run in a compromised context.
- bool ExceptionHandler::SimulateSignalDelivery(int sig) {
-- siginfo_t siginfo = {};
-+ siginfo_t siginfo;
-+ memset(&siginfo, 0, sizeof(siginfo_t));
- // Mimic a trusted signal to allow tracing the process (see
- // ExceptionHandler::HandleSignal().
- siginfo.si_code = SI_USER;
- siginfo.si_pid = getpid();
-- struct ucontext context;
-+ ucontext_t context;
- getcontext(&context);
- return HandleSignal(sig, &siginfo, &context);
- }
-diff --git a/3rdparty/gbreakpad/src/client/linux/handler/exception_handler.h b/3rdparty/gbreakpad/src/client/linux/handler/exception_handler.h
-index 591c310..846df77 100644
---- a/3rdparty/gbreakpad/src/client/linux/handler/exception_handler.h
-+++ b/3rdparty/gbreakpad/src/client/linux/handler/exception_handler.h
-@@ -191,7 +191,7 @@ class ExceptionHandler {
- struct CrashContext {
- siginfo_t siginfo;
- pid_t tid; // the crashing thread.
-- struct ucontext context;
-+ ucontext_t context;
- #if !defined(__ARM_EABI__) && !defined(__mips__)
- // #ifdef this out because FP state is not part of user ABI for Linux ARM.
- // In case of MIPS Linux FP state is already part of struct
-diff --git a/3rdparty/gbreakpad/src/client/linux/microdump_writer/microdump_writer.cc b/3rdparty/gbreakpad/src/client/linux/microdump_writer/microdump_writer.cc
-index 3764eec..80ad5c4 100644
---- a/3rdparty/gbreakpad/src/client/linux/microdump_writer/microdump_writer.cc
-+++ b/3rdparty/gbreakpad/src/client/linux/microdump_writer/microdump_writer.cc
-@@ -593,7 +593,7 @@ class MicrodumpWriter {
-
- void* Alloc(unsigned bytes) { return dumper_->allocator()->Alloc(bytes); }
-
-- const struct ucontext* const ucontext_;
-+ const ucontext_t* const ucontext_;
- #if !defined(__ARM_EABI__) && !defined(__mips__)
- const google_breakpad::fpstate_t* const float_state_;
- #endif
-diff --git a/3rdparty/gbreakpad/src/client/linux/minidump_writer/minidump_writer.cc b/3rdparty/gbreakpad/src/client/linux/minidump_writer/minidump_writer.cc
-index d11ba6e..c716143 100644
---- a/3rdparty/gbreakpad/src/client/linux/minidump_writer/minidump_writer.cc
-+++ b/3rdparty/gbreakpad/src/client/linux/minidump_writer/minidump_writer.cc
-@@ -1323,7 +1323,7 @@ class MinidumpWriter {
- const int fd_; // File descriptor where the minidum should be written.
- const char* path_; // Path to the file where the minidum should be written.
-
-- const struct ucontext* const ucontext_; // also from the signal handler
-+ const ucontext_t* const ucontext_; // also from the signal handler
- #if !defined(__ARM_EABI__) && !defined(__mips__)
- const google_breakpad::fpstate_t* const float_state_; // ditto
- #endif