summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2016-11-25 14:55:42 -0500
committerLeo P2016-11-25 14:55:42 -0500
commit84f09c8cec727dd43bbef82aae75d90637ac1437 (patch)
treec6d0aa0b30ea844878e70eb768d13bff862da397
parentba4b3b94f0c5259b7c3e51a32638b385f8337b16 (diff)
downloadaur-84f09c8cec727dd43bbef82aae75d90637ac1437.tar.gz
update patches
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--redis-2.8.11-use-system-jemalloc.patch15
-rw-r--r--redis-use-system-jemalloc.patch16
-rw-r--r--redis.conf-sane-defaults.patch17
5 files changed, 30 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 615bc983cba5..9799af55b455 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue May 10 19:50:52 UTC 2016
pkgbase = redis-git
pkgdesc = Advanced key-value store (git unstable branch)
- pkgver = r5692.646c958
+ pkgver = r6019.790310d
pkgrel = 1
url = http://redis.io/
install = redis.install
@@ -20,12 +18,12 @@ pkgbase = redis-git
source = redis.service
source = redis.logrotate
source = redis.conf-sane-defaults.patch
- source = redis-2.8.11-use-system-jemalloc.patch
+ source = redis-use-system-jemalloc.patch
md5sums = SKIP
md5sums = afa0f4a9000c26c3323e83fe34883e23
md5sums = 9e2d75b7a9dc421122d673fe520ef17f
- md5sums = 990536d339b694d76415ec1e847b861a
- md5sums = 2ae176578f538e37a67a463258302bc6
+ md5sums = 0edaae8f1ada3add150fa02f601184d7
+ md5sums = 91d1ba6d1e5437c78e6a8ac28dee82bc
pkgname = redis-git
diff --git a/PKGBUILD b/PKGBUILD
index a9a250e80b82..52ab903d4e68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=redis-git
provides=('redis')
conflicts=('redis')
-pkgver=r5692.646c958
+pkgver=r6019.790310d
pkgrel=1
pkgdesc='Advanced key-value store (git unstable branch)'
arch=('i686' 'x86_64')
@@ -17,12 +17,13 @@ source=(git+https://github.com/antirez/redis.git#branch=unstable
redis.service
redis.logrotate
redis.conf-sane-defaults.patch
- redis-2.8.11-use-system-jemalloc.patch)
+ redis-use-system-jemalloc.patch)
md5sums=('SKIP'
'afa0f4a9000c26c3323e83fe34883e23'
'9e2d75b7a9dc421122d673fe520ef17f'
- '990536d339b694d76415ec1e847b861a'
- '2ae176578f538e37a67a463258302bc6')
+ '0edaae8f1ada3add150fa02f601184d7'
+ '91d1ba6d1e5437c78e6a8ac28dee82bc')
+
pkgver() {
cd redis
@@ -32,7 +33,7 @@ pkgver() {
prepare() {
cd redis
patch -p1 -i ../redis.conf-sane-defaults.patch
- patch -p1 -i ../redis-2.8.11-use-system-jemalloc.patch
+ patch -p1 -i ../redis-use-system-jemalloc.patch
}
build() {
diff --git a/redis-2.8.11-use-system-jemalloc.patch b/redis-2.8.11-use-system-jemalloc.patch
deleted file mode 100644
index 5da3d6816fe3..000000000000
--- a/redis-2.8.11-use-system-jemalloc.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: redis-2.8.11/src/Makefile
-===================================================================
---- redis-2.8.11.orig/src/Makefile
-+++ redis-2.8.11/src/Makefile
-@@ -84,8 +84,8 @@ endif
-
- ifeq ($(MALLOC),jemalloc)
- DEPENDENCY_TARGETS+= jemalloc
-- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
-- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a -ldl
-+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
-+ FINAL_LIBS+= -ljemalloc -ldl
- endif
-
- REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
diff --git a/redis-use-system-jemalloc.patch b/redis-use-system-jemalloc.patch
new file mode 100644
index 000000000000..e447f55eafd5
--- /dev/null
+++ b/redis-use-system-jemalloc.patch
@@ -0,0 +1,16 @@
+diff --git a/src/Makefile b/src/Makefile
+index 2bf3c93..8915b0f 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -104,9 +104,8 @@ ifeq ($(MALLOC),tcmalloc_minimal)
+ endif
+
+ ifeq ($(MALLOC),jemalloc)
+- DEPENDENCY_TARGETS+= jemalloc
+- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
+- FINAL_LIBS+= ../deps/jemalloc/lib/libjemalloc.a
++ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
++ FINAL_LIBS+= -ljemalloc
+ endif
+
+ REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
diff --git a/redis.conf-sane-defaults.patch b/redis.conf-sane-defaults.patch
index 97b1086457e2..7c47275c0799 100644
--- a/redis.conf-sane-defaults.patch
+++ b/redis.conf-sane-defaults.patch
@@ -1,8 +1,8 @@
diff --git a/redis.conf b/redis.conf
-index 6efb6ac..344e021 100644
+index adc0902..66d360d 100644
--- a/redis.conf
+++ b/redis.conf
-@@ -45,7 +45,7 @@
+@@ -53,7 +53,7 @@
# Examples:
#
# bind 192.168.1.100 10.0.0.1
@@ -11,16 +11,7 @@ index 6efb6ac..344e021 100644
#
# ~~~ WARNING ~~~ If the computer running Redis is directly exposed to the
# internet, binding to all the interfaces is dangerous and will expose the
-@@ -118,7 +118,7 @@
- # On other kernels the period depends on the kernel configuration.
- #
- # A reasonable value for this option is 60 seconds.
--tcp-keepalive 0
-+tcp-keepalive 60
-
- ################################# GENERAL #####################################
-
-@@ -243,7 +243,7 @@
+@@ -252,7 +252,7 @@ dbfilename dump.rdb
# The Append Only File will also be created inside this directory.
#
# Note that you must specify a directory here, not a file name.
@@ -28,4 +19,4 @@ index 6efb6ac..344e021 100644
+dir /var/lib/redis/
################################# REPLICATION #################################
-
+