summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2018-09-22 13:34:50 -0400
committerLeo P2018-09-22 13:34:50 -0400
commitbe6f97d2a4eabb8d2f2144eee74d4e4ae6d1376d (patch)
tree7d25083cc3ca350b796933e454c0c8a945eeafbe
parent92423bdeec48679421b4f9a71ba962cb325e02f5 (diff)
downloadaur-be6f97d2a4eabb8d2f2144eee74d4e4ae6d1376d.tar.gz
update patches
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--redis-use-system-jemalloc.patch10
-rw-r--r--redis.conf-sane-defaults.patch18
4 files changed, 21 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef5f4ddae634..f837cf8049b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = redis-git
pkgdesc = Advanced key-value store (git unstable branch)
- pkgver = r7054.93238575f
+ pkgver = r7362.0d6f11f4d
pkgrel = 1
url = http://redis.io/
install = redis.install
@@ -19,11 +19,11 @@ pkgbase = redis-git
source = redis.logrotate
source = redis.conf-sane-defaults.patch
source = redis-use-system-jemalloc.patch
- md5sums = SKIP
- md5sums = afa0f4a9000c26c3323e83fe34883e23
- md5sums = 9e2d75b7a9dc421122d673fe520ef17f
- md5sums = 0edaae8f1ada3add150fa02f601184d7
- md5sums = 396f5543b68f3fe96c90dd9d50202ac0
+ sha1sums = SKIP
+ sha1sums = 285476bd6f92aa3dfba40cea1ad6cabef5a94df7
+ sha1sums = b2a3cdc6ea1b89dc867d6db9ce02571e58e8b645
+ sha1sums = 8d60927802707bc7096f1c815e0e64937fc899ad
+ sha1sums = 46fed06e1b37165e1bfb994aaa367c232b83ee43
pkgname = redis-git
diff --git a/PKGBUILD b/PKGBUILD
index 0dd1b06d1e1f..3603f077e598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=redis-git
provides=('redis')
conflicts=('redis')
-pkgver=r7054.93238575f
+pkgver=r7362.0d6f11f4d
pkgrel=1
pkgdesc='Advanced key-value store (git unstable branch)'
arch=('i686' 'x86_64')
@@ -18,12 +18,11 @@ source=(git+https://github.com/antirez/redis.git#branch=unstable
redis.logrotate
redis.conf-sane-defaults.patch
redis-use-system-jemalloc.patch)
-md5sums=('SKIP'
- 'afa0f4a9000c26c3323e83fe34883e23'
- '9e2d75b7a9dc421122d673fe520ef17f'
- '0edaae8f1ada3add150fa02f601184d7'
- '396f5543b68f3fe96c90dd9d50202ac0')
-
+sha1sums=('SKIP'
+ '285476bd6f92aa3dfba40cea1ad6cabef5a94df7'
+ 'b2a3cdc6ea1b89dc867d6db9ce02571e58e8b645'
+ '8d60927802707bc7096f1c815e0e64937fc899ad'
+ '46fed06e1b37165e1bfb994aaa367c232b83ee43')
pkgver() {
cd redis
@@ -33,7 +32,7 @@ pkgver() {
prepare() {
cd redis
patch -p1 -i ../redis.conf-sane-defaults.patch
- patch -p1 -i ../redis-use-system-jemalloc.patch
+ patch -p0 -i ../redis-use-system-jemalloc.patch
}
build() {
diff --git a/redis-use-system-jemalloc.patch b/redis-use-system-jemalloc.patch
index 418cba4a7474..721e9cf5e688 100644
--- a/redis-use-system-jemalloc.patch
+++ b/redis-use-system-jemalloc.patch
@@ -1,8 +1,6 @@
-diff --git a/src/Makefile b/src/Makefile
-index 2bf3c93..8915b0f 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -104,9 +104,8 @@ ifeq ($(MALLOC),tcmalloc_minimal)
+--- src/Makefile 2018-09-22 13:30:15.580979499 -0400
++++ src/Makefile 2018-09-22 13:30:19.690995581 -0400
+@@ -120,9 +120,8 @@
endif
ifeq ($(MALLOC),jemalloc)
@@ -10,7 +8,7 @@ index 2bf3c93..8915b0f 100644
- FINAL_CFLAGS+= -DUSE_JEMALLOC -I../deps/jemalloc/include
- FINAL_LIBS := ../deps/jemalloc/lib/libjemalloc.a $(FINAL_LIBS)
+ FINAL_CFLAGS+= -DUSE_JEMALLOC -DJEMALLOC_NO_DEMANGLE -I/usr/include/jemalloc
-+ FINAL_LIBS:= -ljemalloc $(FINAL_LIBS)
++ FINAL_LIBS+= -ljemalloc
endif
REDIS_CC=$(QUIET_CC)$(CC) $(FINAL_CFLAGS)
diff --git a/redis.conf-sane-defaults.patch b/redis.conf-sane-defaults.patch
index 7c47275c0799..1c4cb9a0acff 100644
--- a/redis.conf-sane-defaults.patch
+++ b/redis.conf-sane-defaults.patch
@@ -1,17 +1,7 @@
-diff --git a/redis.conf b/redis.conf
-index adc0902..66d360d 100644
---- a/redis.conf
-+++ b/redis.conf
-@@ -53,7 +53,7 @@
- # Examples:
- #
- # bind 192.168.1.100 10.0.0.1
--# bind 127.0.0.1 ::1
-+bind 127.0.0.1 ::1
- #
- # ~~~ WARNING ~~~ If the computer running Redis is directly exposed to the
- # internet, binding to all the interfaces is dangerous and will expose the
-@@ -252,7 +252,7 @@ dbfilename dump.rdb
+diff -wbBur redis-3.2.1/redis.conf redis-3.2.1.my/redis.conf
+--- redis-3.2.1/redis.conf 2016-06-17 16:15:21.000000000 +0300
++++ redis-3.2.1.my/redis.conf 2016-06-22 18:06:23.687046141 +0300
+@@ -244,7 +244,7 @@
# The Append Only File will also be created inside this directory.
#
# Note that you must specify a directory here, not a file name.