summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiccardo Berto2019-02-06 21:02:02 +0100
committerRiccardo Berto2019-02-06 21:02:02 +0100
commit7a87b81e57b80dc42350817dfcffb1bd505cc9c8 (patch)
treee15c545a4a50005c3e0382fcf20a87aa796605a1
downloadaur-7a87b81e57b80dc42350817dfcffb1bd505cc9c8.tar.gz
Auto update
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
-rw-r--r--redis-graph.install7
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..480b01d2a9c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = redis-graph
+ pkgdesc = This project is a Redis module that implements a graph database.
+ pkgver = 1.0.13
+ pkgrel = 1
+ url = https://github.com/RedisLabsModules/redis-graph
+ install = redis-graph.install
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ license = AGPL-3.0
+ depends = redis
+ depends = cmake
+ conflicts = redis-graph-git
+ source = https://github.com/RedisLabsModules/redis-graph/archive/v1.0.13.tar.gz
+ sha256sums = SKIP
+
+pkgname = redis-graph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5648d2315ac7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Riccardo Berto <riccardobrt at gmail dot com>
+
+pkgname=redis-graph
+pkgver=1.0.13
+pkgrel=1
+pkgdesc="This project is a Redis module that implements a graph database."
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
+url="https://github.com/RedisLabsModules/$pkgname"
+license=('AGPL-3.0')
+depends=('redis' 'cmake')
+conflicts=('redis-graph-git')
+source=("$url/archive/v1.0.13.tar.gz")
+install=$pkgname.install
+sha256sums=("SKIP")
+
+build() {
+ cd RedisGraph-$pkgver
+ make $MAKEFLAGS
+}
+
+package() {
+ cd $pkgname
+ install -D src/redisgraph.so $pkgdir/usr/lib/redis/redisgraph.so
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/redis-graph.install b/redis-graph.install
new file mode 100644
index 000000000000..88d52286ccdf
--- /dev/null
+++ b/redis-graph.install
@@ -0,0 +1,7 @@
+post_install() {
+ printf "\nDon't forget to update your redis config file and restart Redis.\n\n"
+}
+
+post_remove() {
+ post_install
+}