summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSilvan Gümüsdere2023-03-13 19:04:51 +0100
committerSilvan Gümüsdere2023-03-13 19:05:25 +0100
commitdc83b2101088e20fd5f0a5eb20a54b246e224375 (patch)
tree5a1171bfa7092d4563d1ca59313a505f53700f32
parent6e8565ec5bf0de8751f9ea26ac447c90289ff06b (diff)
downloadaur-dc83b2101088e20fd5f0a5eb20a54b246e224375.tar.gz
v2.10.9
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--redis-graph.install7
3 files changed, 30 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e37417c1fff..7a49542c36d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = redis-graph
- pkgdesc = This project is a Redis module that implements a graph database.
- pkgver = 1.99.4
+ pkgdesc = A graph database as a Redis module
+ pkgver = 2.10.9
pkgrel = 1
- url = https://github.com/RedisLabsModules/redis-graph
- install = redis-graph.install
+ url = https://redis.io/docs/stack/graph/
arch = i686
arch = x86_64
arch = aarch64
arch = armv7h
- license = AGPL-3.0
+ license = custom:SSPL1
+ makedepends = git
+ makedepends = peg
depends = redis
depends = cmake
conflicts = redis-graph-git
- source = https://github.com/RedisLabsModules/redis-graph/archive/v1.99.4.tar.gz
+ source = git+https://github.com/RedisGraph/RedisGraph.git
sha256sums = SKIP
pkgname = redis-graph
-
diff --git a/PKGBUILD b/PKGBUILD
index 8a7572d13998..e1a7bc7d021a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,35 @@
-# Maintainer: Riccardo Berto <riccardobrt at gmail dot com>
+# Maintainer: Silvan Gümüsdere <silvan@trollbox.org>
+# Contributor: Riccardo Berto <riccardobrt at gmail dot com>
pkgname=redis-graph
-pkgver=1.99.4
+_name=RedisGraph
+pkgver=2.10.9
pkgrel=1
-pkgdesc="This project is a Redis module that implements a graph database."
+pkgdesc="A graph database as a Redis module"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
-url="https://github.com/RedisLabsModules/$pkgname"
-license=('AGPL-3.0')
+url="https://redis.io/docs/stack/graph/"
+license=("custom:SSPL1")
+makedepends=('git' 'peg')
depends=('redis' 'cmake')
conflicts=('redis-graph-git')
-source=("$url/archive/v1.99.4.tar.gz")
-install=$pkgname.install
-sha256sums=("SKIP")
+_tag=684918cc14df9a645fb40802cea07af07d49035e # git rev-parse v${pkgver}
+source=(git+https://github.com/${_name}/${_name}.git)
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${_name}
+ git checkout ${_tag}
+ git submodule update --init --recursive
+}
build() {
- cd RedisGraph-$pkgver
- make $MAKEFLAGS
+ cd ${_name}
+ make $MAKEFLAGS
}
package() {
- cd RedisGraph-$pkgver
- install -D src/redisgraph.so $pkgdir/usr/lib/redis/redisgraph.so
- install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ cd ${_name}
+ install -D src/redisgraph.so ${pkgdir}/usr/lib/redis/redisgraph.so
+ install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
}
+
diff --git a/redis-graph.install b/redis-graph.install
deleted file mode 100644
index 88d52286ccdf..000000000000
--- a/redis-graph.install
+++ /dev/null
@@ -1,7 +0,0 @@
-post_install() {
- printf "\nDon't forget to update your redis config file and restart Redis.\n\n"
-}
-
-post_remove() {
- post_install
-}