summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcclin2023-02-15 10:32:12 +0800
committercclin2023-02-15 10:32:12 +0800
commit2021bd74ec5757102dd9a5e9c0883008d5eb6f17 (patch)
tree41925abc4a02bdc2d0a39a011045fe086fd456f7
parent909ed58355f8168a21d0b3c4e00b0d05e53228fd (diff)
downloadaur-2021bd74ec5757102dd9a5e9c0883008d5eb6f17.tar.gz
update to 1.3.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5aeb067a7ce..5e534e2c7720 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = redis-plus-plus
- pkgdesc = A C++ client for Redis based on hiredis written in C++ 11 / C++ 17
- pkgver = 1.3.5
+ pkgdesc = Redis client written in C++
+ pkgver = 1.3.7
pkgrel = 1
url = https://github.com/sewenew/redis-plus-plus
arch = x86_64
license = Apache
makedepends = cmake
- depends = gcc-libs
depends = hiredis
- source = redis-plus-plus-1.3.5.tar.gz::https://github.com/sewenew/redis-plus-plus/archive/1.3.5.tar.gz
- sha256sums = a49a72fef26ed39d36a278fcc4e4d92822e111697b5992d8f26f70d16edc6c1f
+ depends = gcc-libs
+ source = redis-plus-plus-1.3.7.tar.gz::https://github.com/sewenew/redis-plus-plus/archive/1.3.7.tar.gz
+ sha256sums = 89cb83b0a23ac5825300c301814eab74aa3cdcfcd12e87d443c2692e367768ba
pkgname = redis-plus-plus
diff --git a/PKGBUILD b/PKGBUILD
index 3058b247c55a..955f8f7446d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: cclin <cclinet@outlook.com>
pkgname=redis-plus-plus
-pkgver=1.3.5
+pkgver=1.3.7
pkgrel=1
-pkgdesc='A C++ client for Redis based on hiredis written in C++ 11 / C++ 17'
+pkgdesc='Redis client written in C++'
arch=('x86_64')
url="https://github.com/sewenew/redis-plus-plus"
license=('Apache')
-depends=('gcc-libs' 'hiredis')
+depends=('hiredis' 'gcc-libs')
makedepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/sewenew/$pkgname/archive/$pkgver.tar.gz")
build() {
cmake -B build -S "$pkgname-$pkgver" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DREDIS_PLUS_PLUS_BUILD_STATIC=OFF -DREDIS_PLUS_PLUS_BUILD_TEST=OFF -DREDIS_PLUS_PLUS_CXX_STANDARD=17
- make -C build
+ cmake --build build
}
package() {
- make -C build DESTDIR="$pkgdir" PREFIX=/usr install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha256sums=('a49a72fef26ed39d36a278fcc4e4d92822e111697b5992d8f26f70d16edc6c1f')
+sha256sums=('89cb83b0a23ac5825300c301814eab74aa3cdcfcd12e87d443c2692e367768ba')