summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcclin2020-12-30 16:21:52 +0800
committercclin2020-12-30 16:22:17 +0800
commit36573249ab507e13a488494b5b570eaa4dde3a63 (patch)
tree2cad545037931b15dc00dc52a55510235d905adc
parent6ff62842a8036475c3bf9f94224696ebfe5fb127 (diff)
downloadaur-36573249ab507e13a488494b5b570eaa4dde3a63.tar.gz
remove unused cd and fix make -B to make -C
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 416c5547a813..b856b0672346 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = redis-plus-plus
pkgdesc = A C++ client for Redis based on hiredis written in C++ 11 / C++ 17
pkgver = 1.2.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/sewenew/redis-plus-plus
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index d73e5cd1a847..28901321b354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: cclin <cclinet@outlook.com>
pkgname=redis-plus-plus
pkgver=1.2.1
-pkgrel=2
+pkgrel=3
pkgdesc='A C++ client for Redis based on hiredis written in C++ 11 / C++ 17'
arch=('x86_64')
url="https://github.com/sewenew/redis-plus-plus"
@@ -13,11 +13,10 @@ sha256sums=('2a0b5fe5119ec973a0c1966bfc4bd7ed39dbce1cb6d749064af9121fe971936f')
build() {
cmake -B build -S "$pkgname-$pkgver" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DREDIS_PLUS_PLUS_BUILD_STATIC=OFF -DREDIS_PLUS_PLUS_BUILD_TEST=OFF -DREDIS_PLUS_PLUS_CXX_STANDARD=17
- make -B build
+ make -C build
}
package() {
- cd build
- make DESTDIR="$pkgdir" PREFIX=/usr install
+ make -C build DESTDIR="$pkgdir" PREFIX=/usr install
}
sha256sums=('f09c9fcc362955edb887632cd008102887278c94934d7e8c9d0acb8707671902')