summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcclin2020-12-28 14:27:04 +0800
committercclin2020-12-28 14:27:04 +0800
commit6ff62842a8036475c3bf9f94224696ebfe5fb127 (patch)
tree3dfc080179cefff22d8abadfa59b52e441f92f84
parent8799be8c2b9556d6b8dec78a4ca409a664b838b2 (diff)
downloadaur-6ff62842a8036475c3bf9f94224696ebfe5fb127.tar.gz
use c++17
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 219082f6f0ec..416c5547a813 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = redis-plus-plus
- pkgdesc = A C++ client for Redis based on hiredis written in C++ 11 / C++ 17.
+ pkgdesc = A C++ client for Redis based on hiredis written in C++ 11 / C++ 17
pkgver = 1.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sewenew/redis-plus-plus
arch = x86_64
license = Apache
makedepends = cmake
- depends = glibc
+ depends = gcc-libs
depends = hiredis
- source = https://github.com/sewenew/redis-plus-plus/archive/1.2.1.tar.gz
+ source = redis-plus-plus-1.2.1.tar.gz::https://github.com/sewenew/redis-plus-plus/archive/1.2.1.tar.gz
sha256sums = f09c9fcc362955edb887632cd008102887278c94934d7e8c9d0acb8707671902
pkgname = redis-plus-plus
diff --git a/PKGBUILD b/PKGBUILD
index c74e7d890434..d73e5cd1a847 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: cclin <cclinet@outlook.com>
pkgname=redis-plus-plus
pkgver=1.2.1
-pkgrel=1
-pkgdesc='A C++ client for Redis based on hiredis written in C++ 11 / C++ 17.'
+pkgrel=2
+pkgdesc='A C++ client for Redis based on hiredis written in C++ 11 / C++ 17'
arch=('x86_64')
url="https://github.com/sewenew/redis-plus-plus"
license=('Apache')
-depends=('glibc' 'hiredis')
+depends=('gcc-libs' 'hiredis')
makedepends=('cmake')
-source=(https://github.com/sewenew/$pkgname/archive/$pkgver.tar.gz)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sewenew/$pkgname/archive/$pkgver.tar.gz")
sha256sums=('2a0b5fe5119ec973a0c1966bfc4bd7ed39dbce1cb6d749064af9121fe971936f')
build() {
- cmake -B build -S "$pkgname-$pkgver" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DREDIS_PLUS_PLUS_BUILD_STATIC=OFF -DREDIS_PLUS_PLUS_BUILD_TEST=OFF
+ cmake -B build -S "$pkgname-$pkgver" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DREDIS_PLUS_PLUS_BUILD_STATIC=OFF -DREDIS_PLUS_PLUS_BUILD_TEST=OFF -DREDIS_PLUS_PLUS_CXX_STANDARD=17
make -B build
}
package() {
- install -Dm 644 $pkgname-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
cd build
make DESTDIR="$pkgdir" PREFIX=/usr install
}