summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcclin2020-12-28 11:28:48 +0800
committercclin2020-12-28 11:28:48 +0800
commit8799be8c2b9556d6b8dec78a4ca409a664b838b2 (patch)
tree38ca39a870ee21c218ce2872eded4c6f6a368458
downloadaur-8799be8c2b9556d6b8dec78a4ca409a664b838b2.tar.gz
create package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..219082f6f0ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = redis-plus-plus
+ pkgdesc = A C++ client for Redis based on hiredis written in C++ 11 / C++ 17.
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/sewenew/redis-plus-plus
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ depends = glibc
+ depends = hiredis
+ source = https://github.com/sewenew/redis-plus-plus/archive/1.2.1.tar.gz
+ sha256sums = f09c9fcc362955edb887632cd008102887278c94934d7e8c9d0acb8707671902
+
+pkgname = redis-plus-plus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c74e7d890434
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: cclin <cclinet@outlook.com>
+pkgname=redis-plus-plus
+pkgver=1.2.1
+pkgrel=1
+pkgdesc='A C++ client for Redis based on hiredis written in C++ 11 / C++ 17.'
+arch=('x86_64')
+url="https://github.com/sewenew/redis-plus-plus"
+license=('Apache')
+depends=('glibc' 'hiredis')
+makedepends=('cmake')
+source=(https://github.com/sewenew/$pkgname/archive/$pkgver.tar.gz)
+sha256sums=('2a0b5fe5119ec973a0c1966bfc4bd7ed39dbce1cb6d749064af9121fe971936f')
+
+build() {
+ cmake -B build -S "$pkgname-$pkgver" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DREDIS_PLUS_PLUS_BUILD_STATIC=OFF -DREDIS_PLUS_PLUS_BUILD_TEST=OFF
+ make -B build
+}
+
+package() {
+ install -Dm 644 $pkgname-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ cd build
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+sha256sums=('f09c9fcc362955edb887632cd008102887278c94934d7e8c9d0acb8707671902')