summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcclin2022-07-13 11:22:55 +0800
committercclin2022-07-13 11:22:55 +0800
commit909ed58355f8168a21d0b3c4e00b0d05e53228fd (patch)
treeccf50d730bebede03068a0014ffe69b186bd828f
parente52bda88431220d93e3f6f64358840bf309915f3 (diff)
downloadaur-909ed58355f8168a21d0b3c4e00b0d05e53228fd.tar.gz
update to 1.3.5
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD6
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fc8ced48f8d..c5aeb067a7ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = redis-plus-plus
pkgdesc = A C++ client for Redis based on hiredis written in C++ 11 / C++ 17
- pkgver = 1.3.3
+ pkgver = 1.3.5
pkgrel = 1
url = https://github.com/sewenew/redis-plus-plus
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = redis-plus-plus
makedepends = cmake
depends = gcc-libs
depends = hiredis
- source = redis-plus-plus-1.3.3.tar.gz::https://github.com/sewenew/redis-plus-plus/archive/1.3.3.tar.gz
- sha256sums = 23689059b7ba50fcd8fa673c5dbb7bdb010b896b14abad5aa80a5ec48eb64f26
+ source = redis-plus-plus-1.3.5.tar.gz::https://github.com/sewenew/redis-plus-plus/archive/1.3.5.tar.gz
+ sha256sums = a49a72fef26ed39d36a278fcc4e4d92822e111697b5992d8f26f70d16edc6c1f
pkgname = redis-plus-plus
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1fe68a989115
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+redis-plus-plus*
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 08a2385f225f..3058b247c55a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: cclin <cclinet@outlook.com>
pkgname=redis-plus-plus
-pkgver=1.3.3
+pkgver=1.3.5
pkgrel=1
pkgdesc='A C++ client for Redis based on hiredis written in C++ 11 / C++ 17'
arch=('x86_64')
@@ -9,7 +9,6 @@ license=('Apache')
depends=('gcc-libs' 'hiredis')
makedepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/sewenew/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('2a0b5fe5119ec973a0c1966bfc4bd7ed39dbce1cb6d749064af9121fe971936f')
build() {
cmake -B build -S "$pkgname-$pkgver" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DREDIS_PLUS_PLUS_BUILD_STATIC=OFF -DREDIS_PLUS_PLUS_BUILD_TEST=OFF -DREDIS_PLUS_PLUS_CXX_STANDARD=17
@@ -19,5 +18,4 @@ build() {
package() {
make -C build DESTDIR="$pkgdir" PREFIX=/usr install
}
-sha256sums=('f09c9fcc362955edb887632cd008102887278c94934d7e8c9d0acb8707671902')
-sha256sums=('23689059b7ba50fcd8fa673c5dbb7bdb010b896b14abad5aa80a5ec48eb64f26')
+sha256sums=('a49a72fef26ed39d36a278fcc4e4d92822e111697b5992d8f26f70d16edc6c1f')