summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-10 16:25:20 +0800
committerzxp198210052023-09-10 16:25:20 +0800
commit452437ef4cda9f86a1763c73b829949a82ace4ed (patch)
tree8478d7ef4038b8a77d1a91b4d1d35375becc1128
parente71b31de3777c07a686e9694565b5964fc535e25 (diff)
downloadaur-452437ef4cda9f86a1763c73b829949a82ace4ed.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdc72b33afa5..0b972f4a7335 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,12 +9,12 @@ pkgbase = redis-viewer-bin
depends = bash
depends = electron8
depends = glibc
- provides = redis-viewer-2.3.1
+ provides = redis-viewer=2.3.1
conflicts = redis-viewer
source = redis-viewer-2.3.1.deb::https://github.com/redisviewer/RedisViewer/releases/download/v2.3.1/Redis.Viewer-2.3.1.deb
- source = LICENSE::https://raw.githubusercontent.com/redisviewer/RedisViewer/master/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/redisviewer/RedisViewer/v2.3.1/LICENSE
source = redis-viewer.sh
- sha256sums = a5b402a9267b62e52d81dc93469ccef7fe13ffd91e280a92f0bf70e63789dc49
+ sha256sums = 9a06f66d0afb4491c61d46d3ce64dac5c3d08db7e738d625afa1187d82d5720e
sha256sums = 68f3ca5eaa3a59b7e01cbafc7848cb20ea108627ed0c94023e7536adfeeb3e89
sha256sums = 53979f6b74406057a8e9fc21cdbd14fcfd730c8c8847bcbd169dff65b8bb7783
diff --git a/PKGBUILD b/PKGBUILD
index 0fd35c071ff5..1a7956af3aa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,22 +8,25 @@ pkgdesc="A Redis visualization client tool that pursues ultimate performance, mi
arch=('x86_64')
url="https://github.com/redisviewer/RedisViewer"
license=('MIT')
-provides=("${pkgname%-bin}-${pkgver}")
+provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=('hicolor-icon-theme' 'bash' 'electron8' 'glibc')
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/Redis.Viewer-${pkgver}.deb"
- "LICENSE::https://raw.githubusercontent.com/redisviewer/RedisViewer/master/LICENSE"
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_appname// /.}-${pkgver}.deb"
+ "LICENSE::https://raw.githubusercontent.com/redisviewer/RedisViewer/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh")
-sha256sums=('a5b402a9267b62e52d81dc93469ccef7fe13ffd91e280a92f0bf70e63789dc49'
+sha256sums=('9a06f66d0afb4491c61d46d3ce64dac5c3d08db7e738d625afa1187d82d5720e'
'68f3ca5eaa3a59b7e01cbafc7848cb20ea108627ed0c94023e7536adfeeb3e89'
'53979f6b74406057a8e9fc21cdbd14fcfd730c8c8847bcbd169dff65b8bb7783')
-package() {
+prepare() {
bsdtar -xf "${srcdir}/data.tar.xz"
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- cp -r "${srcdir}/opt/${_appname}/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
- chmod 755 "${pkgdir}/opt/${pkgname%-bin}/server/redismanager"
- sed "s|\"/opt/${_appname}/${_pkgname}\" %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g;s|Utility|Utility;Development|g;s|${_pkgname}|${pkgname%-bin}|g" \
+ chmod 755 "${srcdir}/opt/${_appname}/resources/server/redismanager"
+ sed "s|\"/opt/${_appname}/${_pkgname}\" %U|${pkgname%-bin}|g;s|Utility|Utility;Development|g;s|${_pkgname}|${pkgname%-bin}|g" \
-i "${srcdir}/usr/share/applications/${_pkgname}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/opt/${_appname}/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
+ cp -r "${srcdir}/opt/${_appname}/resources/server" "${pkgdir}/opt/${pkgname%-bin}"
install -Dm644 "${srcdir}/usr/share/applications/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${_pkgname}.png" \