summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-04-20 16:45:51 +0800
committerzxp198210052023-04-20 16:45:51 +0800
commit5141895cab3d458a8436f3254ce24fe64ca8bf08 (patch)
tree3a3c9ef916804dbeaa08526e4c6b7f22b6cf66f7
downloadaur-5141895cab3d458a8436f3254ce24fe64ca8bf08.tar.gz
first release
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD22
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b182247d8fbd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = redis-viewer-bin
+ pkgdesc = A Redis visualization client tool that pursues ultimate performance, minimalist layout, efficient interaction, cross platform, and supports deserialization of Java bytecode.
+ pkgver = 2.2.2
+ pkgrel = 1
+ url = https://github.com/redisviewer/RedisViewer
+ arch = x86_64
+ license = MIT
+ depends = hicolor-icon-theme
+ depends = libdrm
+ depends = gcc-libs
+ depends = glibc
+ depends = at-spi2-core
+ depends = libxdamage
+ depends = gtk3
+ depends = nspr
+ depends = libxfixes
+ depends = libcups
+ depends = libxcb
+ depends = libxrandr
+ depends = libxi
+ depends = libxrender
+ depends = libxext
+ depends = dbus
+ depends = libx11
+ depends = libxss
+ depends = pango
+ depends = alsa-lib
+ depends = expat
+ depends = libxcursor
+ depends = libxcomposite
+ depends = gdk-pixbuf2
+ depends = libxtst
+ depends = mesa
+ depends = nss
+ depends = cairo
+ depends = glib2
+ conflicts = redis-viewer
+ conflicts = redis-viewer-appimage
+ options = !strip
+ source = redis-viewer-2.2.2.deb::https://github.com/redisviewer/RedisViewer/releases/download/v2.2.2/Redis.Viewer-2.2.2.deb
+ source = LICENSE::https://github.com/redisviewer/RedisViewer/raw/master/LICENSE
+ sha256sums = eeae331ec3119fbfe773986b43a609a732a95d5fe3932fd5f310ea2b663600eb
+ sha256sums = 68f3ca5eaa3a59b7e01cbafc7848cb20ea108627ed0c94023e7536adfeeb3e89
+
+pkgname = redis-viewer-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..171e084f04e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="redis-viewer-bin"
+pkgver=2.2.2
+pkgrel=1
+pkgdesc="A Redis visualization client tool that pursues ultimate performance, minimalist layout, efficient interaction, cross platform, and supports deserialization of Java bytecode."
+arch=('x86_64')
+url="https://github.com/redisviewer/RedisViewer"
+license=('MIT')
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage")
+providers=()
+depends=('hicolor-icon-theme' 'libdrm' 'gcc-libs' 'glibc' 'at-spi2-core' 'libxdamage' 'gtk3' 'nspr' 'libxfixes' 'libcups' 'libxcb' \
+ 'libxrandr' 'libxi' 'libxrender' 'libxext' 'dbus' 'libx11' 'libxss' 'pango' 'alsa-lib' 'expat' 'libxcursor' 'libxcomposite' \
+ 'gdk-pixbuf2' 'libxtst' 'mesa' 'nss' 'cairo' 'glib2')
+options=(!strip)
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/Redis.Viewer-${pkgver}.deb"
+ "LICENSE::${url}/raw/master/LICENSE")
+sha256sums=('eeae331ec3119fbfe773986b43a609a732a95d5fe3932fd5f310ea2b663600eb'
+ '68f3ca5eaa3a59b7e01cbafc7848cb20ea108627ed0c94023e7536adfeeb3e89')
+package() {
+ bsdtar -xf data.tar.xz -C "${pkgdir}"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file