summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-27 17:06:05 +0800
committerzxp198210052023-11-27 17:06:05 +0800
commit821841fe13638aef71af8803eb611eb7c46fc82a (patch)
tree99532cf1ba7e0f32efd39c95021fcb9544f1d57d
parent946e0bee03d9ebb36fab0635b3309f81442af642 (diff)
downloadaur-821841fe13638aef71af8803eb611eb7c46fc82a.tar.gz
fix errors
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
-rw-r--r--redis-viewer.sh5
3 files changed, 26 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1ae7d6be8a4..eb95554f9c3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = redis-viewer-bin
pkgdesc = A Redis visualization client tool that pursues ultimate performance, minimalist layout, efficient interaction, cross platform, and supports deserialization of Java bytecode.
pkgver = 2.3.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/redisviewer/RedisViewer
arch = x86_64
license = MIT
depends = hicolor-icon-theme
- depends = bash
depends = electron9
- depends = glibc
provides = redis-viewer=2.3.2
conflicts = redis-viewer
source = redis-viewer-2.3.2.deb::https://github.com/redisviewer/RedisViewer/releases/download/v2.3.2/Redis.Viewer-2.3.2.deb
- source = LICENSE::https://raw.githubusercontent.com/redisviewer/RedisViewer/v2.3.2/LICENSE
+ source = LICENSE-2.3.2::https://raw.githubusercontent.com/redisviewer/RedisViewer/v2.3.2/LICENSE
source = redis-viewer.sh
- sha256sums = d67d3ba3a77d4cf4bd41139aa72c39c401e0f2f7d80075158b9f659ff2679365
+ sha256sums = 05782f359b7e9b97027f2aacbe99f6345208e862ee3ebd1046e80a0cf074f844
sha256sums = 68f3ca5eaa3a59b7e01cbafc7848cb20ea108627ed0c94023e7536adfeeb3e89
- sha256sums = baac66b85f91470eeb4f233da7aa1be5ef910d5bfcc71ea764a446f8dffb54dd
+ sha256sums = 570271bd08501ca00e87e32da3b6a003d5dfbce25d9d051a01c5a433e7736a32
pkgname = redis-viewer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 925aaae95dfb..5b97caa1c19c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,27 @@ pkgname=redis-viewer-bin
_pkgname=redisviewer
_appname="Redis Viewer"
pkgver=2.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="A Redis visualization client tool that pursues ultimate performance, minimalist layout, efficient interaction, cross platform, and supports deserialization of Java bytecode."
arch=('x86_64')
url="https://github.com/redisviewer/RedisViewer"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('hicolor-icon-theme' 'bash' 'electron9' 'glibc')
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_appname// /.}-${pkgver}.deb"
- "LICENSE::https://raw.githubusercontent.com/redisviewer/RedisViewer/v${pkgver}/LICENSE"
- "${pkgname%-bin}.sh")
-sha256sums=('d67d3ba3a77d4cf4bd41139aa72c39c401e0f2f7d80075158b9f659ff2679365'
+depends=(
+ 'hicolor-icon-theme'
+ 'electron9'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_appname// /.}-${pkgver}.deb"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/redisviewer/RedisViewer/v${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('05782f359b7e9b97027f2aacbe99f6345208e862ee3ebd1046e80a0cf074f844'
'68f3ca5eaa3a59b7e01cbafc7848cb20ea108627ed0c94023e7536adfeeb3e89'
- 'baac66b85f91470eeb4f233da7aa1be5ef910d5bfcc71ea764a446f8dffb54dd')
+ '570271bd08501ca00e87e32da3b6a003d5dfbce25d9d051a01c5a433e7736a32')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
- chmod 755 "${srcdir}/opt/${_appname}/resources/server/redismanager"
sed -e "s|\"/opt/${_appname}/${_pkgname}\" %U|${pkgname%-bin}|g" \
-e "s|Utility|Development|g" \
-e "s|${_pkgname}|${pkgname%-bin}|g" \
@@ -27,12 +31,15 @@ build() {
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/opt/${_appname}/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
- cp -r "${srcdir}/opt/${_appname}/resources/server" "${pkgdir}/opt/${pkgname%-bin}/resources"
+ install -Dm644 "${srcdir}/opt/${_appname}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/opt/${_appname}/resources/server/redismanager" -t "${pkgdir}/usr/lib/${pkgname%-bin}/server"
+ install -Dm644 "${srcdir}/opt/${_appname}/resources/server/manager.db" -t "${pkgdir}/usr/lib/${pkgname%-bin}/server"
+ install -Dm644 "${srcdir}/opt/${_appname}/resources/server/configs/config.yaml" -t "${pkgdir}/usr/lib/${pkgname%-bin}/server/configs"
+ install -Dm644 "${srcdir}/opt/${_appname}/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
install -Dm644 "${srcdir}/usr/share/applications/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${_pkgname}.png" \
"${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
done
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file
diff --git a/redis-viewer.sh b/redis-viewer.sh
index e704781e7731..370714bd1722 100644
--- a/redis-viewer.sh
+++ b/redis-viewer.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron9
-_ASAR=/opt/redis-viewer/resources/app.asar
+APPDIR="/usr/lib/redis-viewer"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else