summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-08 13:35:16 +0800
committerzxp198210052023-08-08 13:35:16 +0800
commite71b31de3777c07a686e9694565b5964fc535e25 (patch)
treec62032990303f53070800a1990c74265fd4f6dfc
parent9747fdd688bccd10f58be259cdc5795bcce4e2c9 (diff)
downloadaur-e71b31de3777c07a686e9694565b5964fc535e25.tar.gz
fix errors
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD32
-rw-r--r--redis-viewer.sh8
3 files changed, 37 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4405ccc532c8..cdc72b33afa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,44 +1,21 @@
pkgbase = redis-viewer-bin
pkgdesc = A Redis visualization client tool that pursues ultimate performance, minimalist layout, efficient interaction, cross platform, and supports deserialization of Java bytecode.
pkgver = 2.3.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/redisviewer/RedisViewer
arch = x86_64
license = MIT
depends = hicolor-icon-theme
- depends = libdrm
- depends = gcc-libs
+ depends = bash
+ depends = electron8
depends = glibc
- depends = at-spi2-core
- depends = libxdamage
- depends = gtk3
- depends = nspr
- depends = libxfixes
- depends = libcups
- depends = libxcb
- depends = libxrandr
- depends = libxi
- depends = libxrender
- depends = libxext
- depends = dbus
- depends = libx11
- depends = libxss
- depends = pango
- depends = alsa-lib
- depends = expat
- depends = libxcursor
- depends = libxcomposite
- depends = gdk-pixbuf2
- depends = libxtst
- depends = mesa
- depends = nss
- depends = cairo
- depends = glib2
+ provides = redis-viewer-2.3.1
conflicts = redis-viewer
- conflicts = redis-viewer-appimage
source = redis-viewer-2.3.1.deb::https://github.com/redisviewer/RedisViewer/releases/download/v2.3.1/Redis.Viewer-2.3.1.deb
- source = https://raw.githubusercontent.com/redisviewer/RedisViewer/master/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/redisviewer/RedisViewer/master/LICENSE
+ source = redis-viewer.sh
sha256sums = a5b402a9267b62e52d81dc93469ccef7fe13ffd91e280a92f0bf70e63789dc49
sha256sums = 68f3ca5eaa3a59b7e01cbafc7848cb20ea108627ed0c94023e7536adfeeb3e89
+ sha256sums = 53979f6b74406057a8e9fc21cdbd14fcfd730c8c8847bcbd169dff65b8bb7783
pkgname = redis-viewer-bin
diff --git a/PKGBUILD b/PKGBUILD
index f03ee37a84ad..0fd35c071ff5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,33 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname="redis-viewer-bin"
+pkgname=redis-viewer-bin
+_pkgname=redisviewer
+_appname="Redis Viewer"
pkgver=2.3.1
-pkgrel=2
+pkgrel=3
pkgdesc="A Redis visualization client tool that pursues ultimate performance, minimalist layout, efficient interaction, cross platform, and supports deserialization of Java bytecode."
arch=('x86_64')
url="https://github.com/redisviewer/RedisViewer"
license=('MIT')
-conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage")
-depends=('hicolor-icon-theme' 'libdrm' 'gcc-libs' 'glibc' 'at-spi2-core' 'libxdamage' 'gtk3' 'nspr' 'libxfixes' 'libcups' 'libxcb' \
- 'libxrandr' 'libxi' 'libxrender' 'libxext' 'dbus' 'libx11' 'libxss' 'pango' 'alsa-lib' 'expat' 'libxcursor' 'libxcomposite' \
- 'gdk-pixbuf2' 'libxtst' 'mesa' 'nss' 'cairo' 'glib2')
+provides=("${pkgname%-bin}-${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=('hicolor-icon-theme' 'bash' 'electron8' 'glibc')
source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/Redis.Viewer-${pkgver}.deb"
- https://raw.githubusercontent.com/redisviewer/RedisViewer/master/LICENSE)
+ "LICENSE::https://raw.githubusercontent.com/redisviewer/RedisViewer/master/LICENSE"
+ "${pkgname%-bin}.sh")
sha256sums=('a5b402a9267b62e52d81dc93469ccef7fe13ffd91e280a92f0bf70e63789dc49'
- '68f3ca5eaa3a59b7e01cbafc7848cb20ea108627ed0c94023e7536adfeeb3e89')
+ '68f3ca5eaa3a59b7e01cbafc7848cb20ea108627ed0c94023e7536adfeeb3e89'
+ '53979f6b74406057a8e9fc21cdbd14fcfd730c8c8847bcbd169dff65b8bb7783')
package() {
- bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+ bsdtar -xf "${srcdir}/data.tar.xz"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ cp -r "${srcdir}/opt/${_appname}/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ chmod 755 "${pkgdir}/opt/${pkgname%-bin}/server/redismanager"
+ sed "s|\"/opt/${_appname}/${_pkgname}\" %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g;s|Utility|Utility;Development|g;s|${_pkgname}|${pkgname%-bin}|g" \
+ -i "${srcdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 "${srcdir}/usr/share/applications/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${_pkgname}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png"
+ done
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- chmod 755 "${pkgdir}/opt/Redis Viewer/resources/server/redismanager"
} \ No newline at end of file
diff --git a/redis-viewer.sh b/redis-viewer.sh
new file mode 100644
index 000000000000..c112a046af74
--- /dev/null
+++ b/redis-viewer.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron8
+_ASAR=/opt/redis-viewer/app.asar
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file