summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteinGaming2023-03-11 15:06:58 +0100
committerSteinGaming2023-03-11 15:06:58 +0100
commit16dba2f539d21836dd77b532255e1fa863f77270 (patch)
tree72226242fed78507b9cc5fef69b51cdd4db5d148
parentee438276b54fb0b8f312fcad83d87748a73b6060 (diff)
downloadaur-16dba2f539d21836dd77b532255e1fa863f77270.tar.gz
feat: Use github repository instead of official URL; upgrade: v2.20.0
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD31
2 files changed, 35 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0715f4855a8f..f80f04bbfc0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = redisinsight
- pkgdesc = Desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data.
- pkgver = 2.18.0
- pkgrel = 1
- url = https://redis.com/redis-enterprise/redis-insight
- arch = x86_64
- license = custom:SSPL
- makedepends = gendesk
- depends = dbus-glib
- depends = nss
- depends = libindicator-gtk2
- depends = gtk3
- depends = libdbusmenu-gtk2
- depends = alsa-lib
- noextract = redisinsight-2.8.0.AppImage
- source = redisinsight-2.8.0.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-v2-linux-x86_64.AppImage
- source = LICENSE::https://raw.githubusercontent.com/RedisInsight/RedisInsight/main/LICENSE
- sha256sums = 57d50a9794ffb388de3fb7bc58013579f27e2c784b0efb5dc4bf1229cb844c7c
- sha256sums = 723a1b274ff1653c4414fa9133b11cae6cc0b258af7617967d50c04fa4354c9e
+pkgdesc = Desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data.
+pkgver = 2.20.0
+pkgrel = 1
+url = https://redis.com/redis-enterprise/redis-insight
+arch = x86_64
+license = custom:SSPL
+makedepends = gendesk
+makedepends = nodejs
+makedepends = yarn
+depends = dbus-glib
+depends = nss
+depends = libindicator-gtk2
+depends = gtk3
+depends = libdbusmenu-gtk2
+depends = alsa-lib
+source = git+https://github.com/RedisInsight/RedisInsight.git
+sha256sums = SKIP
pkgname = redisinsight
diff --git a/PKGBUILD b/PKGBUILD
index 0a09754aee5c..6b81da777606 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dan Walsh <dan@danwalsh.ca>
pkgname=redisinsight
-pkgver=2.18.0
+pkgver=2.20.0
pkgrel=1
pkgdesc="Desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data."
arch=('x86_64')
@@ -12,17 +12,21 @@ depends=('dbus-glib'
'gtk3'
'libdbusmenu-gtk2'
'alsa-lib')
-makedepends=('gendesk')
-noextract=("${pkgname}-${pkgver}.AppImage")
-source=("${pkgname}-${pkgver}.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-v2-linux-x86_64.AppImage"
- "LICENSE::https://raw.githubusercontent.com/RedisInsight/RedisInsight/main/LICENSE")
-sha256sums=('57d50a9794ffb388de3fb7bc58013579f27e2c784b0efb5dc4bf1229cb844c7c'
- '723a1b274ff1653c4414fa9133b11cae6cc0b258af7617967d50c04fa4354c9e')
+makedepends=('gendesk' 'nodejs' 'yarn')
+source=("git+https://github.com/RedisInsight/RedisInsight.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/RedisInsight"
+ git checkout "release/$pkgver"
+ yarn install
+ yarn --cwd redisinsight/api/
+ NODE_OPTIONS=--openssl-legacy-provider yarn package:prod
+}
package() {
- chmod 755 ./${pkgname}-${pkgver}.AppImage
- ./${pkgname}-${pkgver}.AppImage --appimage-extract
- install -Dm644 squashfs-root/usr/share/icons/hicolor/512x512/apps/redisinsight.png "${pkgdir}/usr/share/pixmaps/redisinsight.png"
+ cd "$srcdir/RedisInsight/release/linux-unpacked"
+ install -Dm644 resources/resources/icons/512x512.png "${pkgdir}/usr/share/pixmaps/redisinsight.png"
gendesk -f -n --pkgname "${pkgname}" \
--pkgdesc "$pkgdesc" \
--name "RedisInsight" \
@@ -31,10 +35,11 @@ package() {
--categories 'Development' \
--icon "${pkgname}"
install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 resources/LICENSE.redisinsight.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/opt"
- cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname}"
- ln -s /opt/${pkgname}/AppRun "${pkgdir}/usr/bin/redisinsight"
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -avR * "${pkgdir}/opt/${pkgname}"
+ ln -s /opt/${pkgname}/redisinsight "${pkgdir}/usr/bin/redisinsight"
find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} +
}