summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorАлександр Ивлев2022-01-07 18:01:36 +0300
committerАлександр Ивлев2022-01-07 18:01:36 +0300
commit292cb274f2b675a3c3ff87463cc991579c80c7da (patch)
tree4e784bc334abc23121e6d00648633bedd51c7673
downloadaur-292cb274f2b675a3c3ff87463cc991579c80c7da.tar.gz
Initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dde6a81df183
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = redisinsight
+ pkgdesc = RedisInsight is a desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data.
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://redis.com/redis-enterprise/redis-insight
+ arch = x86_64
+ license = custom:unknown
+ makedepends = gendesk
+ noextract = redisinsight-2.0.3.AppImage
+ source = redisinsight-2.0.3.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-preview-linux.AppImage
+ sha256sums = b654998755b34e563aa670054492081a99049e565830bc927f020dd29ad585c0
+
+pkgname = redisinsight
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8056fb05ae49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=redisinsight
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="RedisInsight is a desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data."
+arch=('x86_64')
+url='https://redis.com/redis-enterprise/redis-insight'
+license=('custom:unknown')
+makedepends=('gendesk')
+noextract=("${pkgname}-${pkgver}.AppImage")
+source=("${pkgname}-${pkgver}.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-preview-linux.AppImage")
+sha256sums=('b654998755b34e563aa670054492081a99049e565830bc927f020dd29ad585c0')
+
+package() {
+ chmod 755 ./${pkgname}-${pkgver}.AppImage
+ ./${pkgname}-${pkgver}.AppImage --appimage-extract
+ install -Dm644 squashfs-root/usr/share/icons/hicolor/512x512/apps/redisinsight.png "${pkgdir}/usr/share/pixmaps/redisinsight.png"
+ gendesk -f -n --pkgname "${pkgname}" \
+ --pkgdesc "$pkgdesc" \
+ --name "RedisInsight" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname}" \
+ --categories 'Development' \
+ --icon "${pkgname}"
+ install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/opt"
+ cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname}"
+ ln -s /opt/${pkgname}/AppRun "${pkgdir}/usr/bin/redisinsight"
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} +
+}