summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Walsh2022-02-11 19:23:09 -0500
committerDan Walsh2022-02-11 19:29:04 -0500
commitc458d48174047d746a2aa09d2cc2f4d8ef88f25a (patch)
tree8a1facb20b5110f0d9d9af454b99c5d33023f72b
parent292cb274f2b675a3c3ff87463cc991579c80c7da (diff)
downloadaur-c458d48174047d746a2aa09d2cc2f4d8ef88f25a.tar.gz
Updated to 2.0.4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
2 files changed, 28 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dde6a81df183..492ef43f0aa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
pkgbase = redisinsight
- pkgdesc = RedisInsight is a desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data.
- pkgver = 2.0.3
+ pkgdesc = Desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data.
+ pkgver = 2.0.4
pkgrel = 1
url = https://redis.com/redis-enterprise/redis-insight
arch = x86_64
- license = custom:unknown
+ license = custom:SSPL
makedepends = gendesk
- noextract = redisinsight-2.0.3.AppImage
- source = redisinsight-2.0.3.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-preview-linux.AppImage
- sha256sums = b654998755b34e563aa670054492081a99049e565830bc927f020dd29ad585c0
+ depends = dbus-glib
+ depends = nss
+ depends = libindicator-gtk2
+ depends = gtk3
+ depends = libdbusmenu-gtk2
+ noextract = redisinsight-2.0.4.AppImage
+ source = redisinsight-2.0.4.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-preview-linux.AppImage
+ source = LICENSE::https://raw.githubusercontent.com/RedisInsight/RedisInsight/main/LICENSE
+ sha256sums = a4a1253b2fb5e22ff3b48dfd6b398e130542cd02cf94d12419f24dc2748310b0
+ sha256sums = 723a1b274ff1653c4414fa9133b11cae6cc0b258af7617967d50c04fa4354c9e
pkgname = redisinsight
diff --git a/PKGBUILD b/PKGBUILD
index 8056fb05ae49..6aed7a91eb5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,22 @@
+# Maintainer: Dan Walsh <dan@danwalsh.ca>
pkgname=redisinsight
-pkgver=2.0.3
+pkgver=2.0.4
pkgrel=1
-pkgdesc="RedisInsight is a desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data."
+pkgdesc="Desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data."
arch=('x86_64')
url='https://redis.com/redis-enterprise/redis-insight'
-license=('custom:unknown')
+license=('custom:SSPL')
+depends=('dbus-glib'
+ 'nss'
+ 'libindicator-gtk2'
+ 'gtk3'
+ 'libdbusmenu-gtk2')
makedepends=('gendesk')
noextract=("${pkgname}-${pkgver}.AppImage")
-source=("${pkgname}-${pkgver}.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-preview-linux.AppImage")
-sha256sums=('b654998755b34e563aa670054492081a99049e565830bc927f020dd29ad585c0')
+source=("${pkgname}-${pkgver}.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-preview-linux.AppImage"
+ "LICENSE::https://raw.githubusercontent.com/RedisInsight/RedisInsight/main/LICENSE")
+sha256sums=('a4a1253b2fb5e22ff3b48dfd6b398e130542cd02cf94d12419f24dc2748310b0'
+ '723a1b274ff1653c4414fa9133b11cae6cc0b258af7617967d50c04fa4354c9e')
package() {
chmod 755 ./${pkgname}-${pkgver}.AppImage
@@ -22,9 +30,10 @@ package() {
--categories 'Development' \
--icon "${pkgname}"
install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/opt"
cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname}"
ln -s /opt/${pkgname}/AppRun "${pkgdir}/usr/bin/redisinsight"
find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} +
-}
+} \ No newline at end of file