summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Walsh2022-02-11 19:23:09 -0500
committerDan Walsh2022-02-11 19:23:09 -0500
commitcb6b3b19e8b055b4a9e3566131c26ebe2332ad21 (patch)
tree87eded4a0ac05a0fc387264dbf37cb91fdd33c5c
parent292cb274f2b675a3c3ff87463cc991579c80c7da (diff)
downloadaur-cb6b3b19e8b055b4a9e3566131c26ebe2332ad21.tar.gz
Updated to 2.0.4
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8056fb05ae49..6aed7a91eb5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,22 @@
+# Maintainer: Dan Walsh <dan@danwalsh.ca>
pkgname=redisinsight
-pkgver=2.0.3
+pkgver=2.0.4
pkgrel=1
-pkgdesc="RedisInsight is a desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data."
+pkgdesc="Desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data."
arch=('x86_64')
url='https://redis.com/redis-enterprise/redis-insight'
-license=('custom:unknown')
+license=('custom:SSPL')
+depends=('dbus-glib'
+ 'nss'
+ 'libindicator-gtk2'
+ 'gtk3'
+ 'libdbusmenu-gtk2')
makedepends=('gendesk')
noextract=("${pkgname}-${pkgver}.AppImage")
-source=("${pkgname}-${pkgver}.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-preview-linux.AppImage")
-sha256sums=('b654998755b34e563aa670054492081a99049e565830bc927f020dd29ad585c0')
+source=("${pkgname}-${pkgver}.AppImage::https://download.redisinsight.redis.com/latest/RedisInsight-preview-linux.AppImage"
+ "LICENSE::https://raw.githubusercontent.com/RedisInsight/RedisInsight/main/LICENSE")
+sha256sums=('a4a1253b2fb5e22ff3b48dfd6b398e130542cd02cf94d12419f24dc2748310b0'
+ '723a1b274ff1653c4414fa9133b11cae6cc0b258af7617967d50c04fa4354c9e')
package() {
chmod 755 ./${pkgname}-${pkgver}.AppImage
@@ -22,9 +30,10 @@ package() {
--categories 'Development' \
--icon "${pkgname}"
install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/opt"
cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname}"
ln -s /opt/${pkgname}/AppRun "${pkgdir}/usr/bin/redisinsight"
find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} +
-}
+} \ No newline at end of file