summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteinGaming2023-03-12 21:07:17 +0100
committerSteinGaming2023-03-12 21:07:17 +0100
commitf4e0662ebeb8886994a2bf1db09c8d4c6e491d6c (patch)
tree06e4c5da2293ae7182c56be09590b0d52d719b94
parent16dba2f539d21836dd77b532255e1fa863f77270 (diff)
downloadaur-f4e0662ebeb8886994a2bf1db09c8d4c6e491d6c.tar.gz
fix: don't use git as it requires it as a makedepend, instead download it from the archive; only build linux-unpacked, no distributionables
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD12
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f80f04bbfc0f..10b9ae22d83a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = redisinsight
-pkgdesc = Desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data.
-pkgver = 2.20.0
-pkgrel = 1
-url = https://redis.com/redis-enterprise/redis-insight
-arch = x86_64
-license = custom:SSPL
-makedepends = gendesk
-makedepends = nodejs
-makedepends = yarn
-depends = dbus-glib
-depends = nss
-depends = libindicator-gtk2
-depends = gtk3
-depends = libdbusmenu-gtk2
-depends = alsa-lib
-source = git+https://github.com/RedisInsight/RedisInsight.git
-sha256sums = SKIP
+ pkgdesc = Desktop manager that provides an intuitive and efficient GUI for Redis, allowing you to interact with your databases, monitor, and manage your data.
+ pkgver = 2.20.0
+ pkgrel = 1
+ url = https://redis.com/redis-enterprise/redis-insight
+ arch = x86_64
+ license = custom:SSPL
+ makedepends = gendesk
+ makedepends = nodejs
+ makedepends = yarn
+ depends = dbus-glib
+ depends = nss
+ depends = libindicator-gtk2
+ depends = gtk3
+ depends = libdbusmenu-gtk2
+ depends = alsa-lib
+ source = redisinsight-2.20.0::https://github.com/RedisInsight/RedisInsight/archive/2.20.0.tar.gz
+ sha256sums = f9e436bc20f566902e9291b6f45633ecd7b6d1110d22e0ee30a1a34e8d2216d6
pkgname = redisinsight
diff --git a/PKGBUILD b/PKGBUILD
index 6b81da777606..489b2a907bde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,19 +13,19 @@ depends=('dbus-glib'
'libdbusmenu-gtk2'
'alsa-lib')
makedepends=('gendesk' 'nodejs' 'yarn')
-source=("git+https://github.com/RedisInsight/RedisInsight.git")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver::https://github.com/RedisInsight/RedisInsight/archive/$pkgver.tar.gz")
+sha256sums=('f9e436bc20f566902e9291b6f45633ecd7b6d1110d22e0ee30a1a34e8d2216d6')
build() {
- cd "$srcdir/RedisInsight"
- git checkout "release/$pkgver"
+ cd "$srcdir/RedisInsight-$pkgver"
yarn install
yarn --cwd redisinsight/api/
- NODE_OPTIONS=--openssl-legacy-provider yarn package:prod
+ NODE_OPTIONS=--openssl-legacy-provider yarn build:prod
+ yarn electron-builder build --dir -p never
}
package() {
- cd "$srcdir/RedisInsight/release/linux-unpacked"
+ cd "$srcdir/RedisInsight-$pkgver/release/linux-unpacked"
install -Dm644 resources/resources/icons/512x512.png "${pkgdir}/usr/share/pixmaps/redisinsight.png"
gendesk -f -n --pkgname "${pkgname}" \
--pkgdesc "$pkgdesc" \