summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-01-31 01:08:16 +0000
committerGeorge Rawlinson2022-01-31 01:08:16 +0000
commit8a38383c012e35ee36f910cd32214cf45e174a6d (patch)
tree12bfe1f1fc2004c70c2626e14642f903eaa8436b
parenta1f40a8a27262787e8015cde8991ec6843b772fa (diff)
downloadaur-8a38383c012e35ee36f910cd32214cf45e174a6d.tar.gz
upgpkg: redo-c 0.3-2
Use CFLAGS when building.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87a7f8ecd5df..8f8ed03263db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = redo-c
pkgdesc = An implementation of the redo build system in portable C with zero dependencies
pkgver = 0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/leahneukirchen/redo-c
arch = x86_64
license = custom:CC0-1.0
diff --git a/PKGBUILD b/PKGBUILD
index 6c0adc8be1d5..e8af880e7854 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=redo-c
pkgver=0.3
-pkgrel=1
+pkgrel=2
pkgdesc="An implementation of the redo build system in portable C with zero dependencies"
arch=('x86_64')
url="https://github.com/leahneukirchen/redo-c"
@@ -27,8 +27,7 @@ pkgver() {
build() {
cd "$pkgname"
- # TODO add CFLAGS
- cc -o redo redo.c "$LDFLAGS"
+ cc $CFLAGS -o redo redo.c $LDFLAGS
}
package() {