summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-10-20 21:03:34 +0200
committeraksr2015-10-20 21:03:34 +0200
commitec204d1f85637ddfbaeeda4715a0ee05231d177f (patch)
treeb6a6f954ae4abc93bb945969bac1f75da5beb9f6
downloadaur-ec204d1f85637ddfbaeeda4715a0ee05231d177f.tar.gz
Start.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b8c5d93d34f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = redo-c-git
+ pkgdesc = An implementation of the redo build system in portable C with zero dependencies.
+ pkgver = r50.eeb9498
+ pkgrel = 1
+ url = https://github.com/chneukirchen/redo-c
+ arch = i686
+ arch = x86_64
+ license = publicdomain
+ makedepends = git
+ source = redo-c-git::git+https://github.com/chneukirchen/redo-c
+ md5sums = SKIP
+
+pkgname = redo-c-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..753d2fb8c256
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=redo-c-git
+pkgver=r50.eeb9498
+pkgrel=1
+epoch=
+pkgdesc="An implementation of the redo build system in portable C with zero dependencies."
+arch=('i686' 'x86_64')
+url="https://github.com/chneukirchen/redo-c"
+license=('publicdomain')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/chneukirchen/redo-c")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ gcc -g -Os -Wall -Wextra -Wwrite-strings -o redo redo.c
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 redo $pkgdir/usr/bin/redo
+ install -Dm755 redo-sources $pkgdir/usr/bin/redo-sources
+ install -Dm755 redo-targets $pkgdir/usr/bin/redo-targets
+ install -Dm644 NOTES $pkgdir/usr/share/doc/$pkgname/NOTES
+}
+