summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÁrni Dagur2019-02-08 13:55:34 +0000
committerÁrni Dagur2019-02-08 13:55:34 +0000
commitf2d377c2cfc57a349b95960502b48357ff463e10 (patch)
tree29d0b3bbe588ebdf1178ec45aa73e31afd0d2487
downloadaur-f2d377c2cfc57a349b95960502b48357ff463e10.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bae54d09515b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = redox-games-git
+ pkgdesc = Games for Redox OS (and Linux) in the terminal
+ pkgver = r143.1e234c6
+ pkgrel = 1
+ url = https://gitlab.redox-os.org/redox-os/games
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ source = redox-games-git::git+https://gitlab.redox-os.org/redox-os/games.git
+ sha512sums = SKIP
+
+pkgname = redox-games-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64d89f058f89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Árni Dagur <arnidg@protonmail.ch>
+
+pkgname="redox-games-git"
+pkgver=r143.1e234c6
+pkgrel=1
+pkgdesc="Games for Redox OS (and Linux) in the terminal"
+arch=('x86_64')
+url='https://gitlab.redox-os.org/redox-os/games'
+license=('MIT')
+makedepends=('rust' 'cargo')
+source=("$pkgname::git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ cargo build --release --locked
+}
+
+check() {
+ cd $pkgname
+ cargo test --release --locked
+}
+
+package() {
+ cd $pkgname
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm755 target/release/{baduk,commie,dem,flappy,h4xx3r,ice,minesweeper,reblox,redoku,rusthello,snake} "$pkgdir/usr/bin"
+
+ mkdir -p "$pkgdir/usr/share/license"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_shortname}/LICENSE"
+}