summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangzhichao2022-10-11 10:59:33 +0800
committerwangzhichao2022-10-11 10:59:33 +0800
commit214a10c675fc24dbae1792d55e5586d07dd75a51 (patch)
tree1f675171f62cd174d8940d98abcd1ce6178b2243
downloadaur-214a10c675fc24dbae1792d55e5586d07dd75a51.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
-rwxr-xr-xredpandaide.desktop15
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3782bbb148a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = redpanda-cpp-git
+ pkgdesc = A lightweighted QT-based C/C++ IDE
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/royqh1979/RedPanda-CPP
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ makedepends = qt5-base
+ optdepends = git: for git support
+ source = git+https://github.com/royqh1979/RedPanda-CPP.git
+ source = redpandaide.desktop
+ sha256sums = SKIP
+ sha256sums = 8b5b7a27e7ea3ac31bdab6451a40124398a6c6625e64cf9cb6c2664b6939527a
+
+pkgname = redpanda-cpp-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ca1a3b1df75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: wangzhichao <wangzhichao1990@126.com>
+pkgname=redpanda-cpp-git
+pkgver=1.4
+pkgrel=1
+pkgdesc="A lightweighted QT-based C/C++ IDE"
+arch=('x86_64')
+url="https://github.com/royqh1979/RedPanda-CPP"
+license=('GPL3')
+makedepends=(git make qt5-base)
+optdepends=('git: for git support')
+source=("git+https://github.com/royqh1979/RedPanda-CPP.git" "redpandaide.desktop")
+sha256sums=('SKIP' '8b5b7a27e7ea3ac31bdab6451a40124398a6c6625e64cf9cb6c2664b6939527a' )
+
+build() {
+ cd RedPanda-CPP/
+ qmake Red_Panda_CPP.pro
+ make -j8
+}
+
+package() {
+ mkdir -p ${pkgdir}/opt/
+ cp -r ${srcdir}/RedPanda-CPP/RedPandaIDE ${pkgdir}/opt/
+ install -Dm644 ${srcdir}/redpandaide.desktop ${pkgdir}/usr/share/applications/redpandaide.desktop
+}
diff --git a/redpandaide.desktop b/redpandaide.desktop
new file mode 100755
index 000000000000..66a4034a1623
--- /dev/null
+++ b/redpandaide.desktop
@@ -0,0 +1,15 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Comment=A lightweighted QT-based C/C++ IDE
+Comment[zh_CN]=基于QT的轻量级C/C++集成开发环境
+Exec=/opt/RedPandaIDE/RedPandaIDE %F
+GenericName=Red Panda C++
+GenericName[zh_CN]=小熊猫C++
+MimeType=application/pdf
+Name=Red Panda C++
+Name[zh_CN]=小熊猫C++
+StartupNotify=false
+Terminal=false
+Type=Application
+Categories=Development;Qt;
+Icon=/opt/RedPandaIDE/images/devcpp.png