summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkeystroke32021-01-25 15:55:59 +0300
committerkeystroke32021-01-25 15:55:59 +0300
commit1c6542ae0ea28ca35f6c7f8e65ef928c86744a55 (patch)
tree15d13ef22b12d5ba97176960b89126edf7231dc2
downloadaur-1c6542ae0ea28ca35f6c7f8e65ef928c86744a55.tar.gz
Initial push
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fd386fb0d8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = redpaper-git
+ pkgdesc = Wallpaper downloader and setter that fetches from Reddit
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/keystroke3/redpaper
+ arch = any
+ license = GPLv3+
+ makedepends = git
+ depends = python>=3.7
+ depends = python-pillow
+ depends = python-praw
+ depends = python-gobject
+ depends = python-requests
+ depends = feh
+ provides = redpaper
+ source = redpaper-git::git+https://github.com/keystroke3/redpaper
+ md5sums = SKIP
+
+pkgname = redpaper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80eaf9d8bfe8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Salvaje <keystroke33@gmail.com>
+pkgname=redpaper-git
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Wallpaper downloader and setter that fetches from Reddit"
+arch=('any')
+url="https://github.com/keystroke3/redpaper"
+license=('GPLv3+')
+depends=('python>=3.7'
+ 'python-pillow'
+ 'python-praw'
+ 'python-gobject'
+ 'python-requests'
+ 'feh'
+ )
+makedepends=('git')
+provides=('redpaper')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+package() {
+ cd $pkgname
+ install -Dm755 src/redpaper.py -t "$pkgdir/opt/$pkgname"
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/$pkgname/redpaper.py" "$pkgdir/usr/bin/redpaper"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}