summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCubeTheThird2017-06-04 22:09:07 -0400
committerCubeTheThird2017-06-04 22:09:07 -0400
commit59ce121cb96fdc999e133d75eba56033f610acd0 (patch)
treee9b98e6ce24563f3ed673521f43e50e09e531b88
downloadaur-59ce121cb96fdc999e133d75eba56033f610acd0.tar.gz
Initial commit for PKGBUILD.
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD41
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a403c34f8332
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = redshift-gnomerr-git
+ pkgdesc = Adjusts the color temperature of your screen according to your surroundings, with experimental Wayland support through gnomerr.
+ pkgver = 1.11.r32.gd417c96
+ pkgrel = 1
+ url = https://github.com/prahal/redshift/tree/add-gnomerr-method
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = intltool
+ makedepends = python
+ depends = libxxf86vm
+ depends = libdrm
+ depends = libxcb
+ depends = geoclue2
+ provides = redshift
+ conflicts = redshift
+ source = redshift::git+https://github.com/prahal/redshift.git#branch=add-gnomerr-method
+ md5sums = SKIP
+
+pkgname = redshift-gnomerr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cf39d694f56b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# source files
+*.pkg.tar.xz
+pkg/**
+src/**
+redshift/**
+build.sh
+test.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..424822bd6475
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: CubeTheThird <cubethethird@gmail.com>
+# Contributor: Andrey Solomatin <toadron[at]yandex[dot]ru>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Geoffrey Teale <tealeg@stop-squark>
+# Contributor: Mark, Huo Mian <markhuomian[at]gmail[dot]com>
+# Contributor: Biginoz <biginoz a free dot fr>
+# Contributor: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname='redshift-gnomerr-git'
+pkgver=1.11.r32.gd417c96
+pkgrel=1
+pkgdesc='Adjusts the color temperature of your screen according to your surroundings, with experimental Wayland support through gnomerr.'
+arch=('i686' 'x86_64')
+url='https://github.com/prahal/redshift/tree/add-gnomerr-method'
+license=('GPL3')
+provides=('redshift')
+conflicts=('redshift')
+depends=('libxxf86vm' 'libdrm' 'libxcb' 'geoclue2')
+makedepends=('git' 'intltool' 'python')
+source=(redshift::"git+https://github.com/prahal/redshift.git#branch=add-gnomerr-method")
+md5sums=('SKIP')
+
+pkgver() {
+ cd redshift
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./g'
+}
+
+build() {
+ cd redshift
+
+ ./bootstrap
+ ./configure --prefix=/usr --enable-randr --enable-drm --enable-vidmode --enable-geoclue2 \
+ --with-systemduserunitdir=/usr/lib/systemd/user
+ make
+}
+
+package() {
+ cd redshift
+ make DESTDIR="$pkgdir" install
+}